[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DSA concerns for jessie architectures (mips*)

On Tue, Jun 25, 2013 at 10:33 AM,  <chenhc@lemote.com> wrote:
>> On Tue, Jun 25, 2013 at 9:48 AM,  <chenhc@lemote.com> wrote:
>>>> On Tue, Jun 25, 2013 at 9:16 AM, Fuxin Zhang <fxzhang@ict.ac.cn> wrote:
>>>>> Dear Andreas,
>>>>> 亁   2013/6/25 3:20, Andreas Barth 写道:
>>>>>>>> 3. We have currently two new machines with loongson 3a processors
>>>>>>>> to
>>>>>>>> test. It will take a bit of time to finally get a working kernel on
>>>>>>>> these, but that would also decrease build-times quite much.
>>>>>>> When do you expect them to be usable?
>>>>>> Depends on your definition of useable.
>>>>>> I'm currently in the process to get the kernel building and trying to
>>>>>> get the patches into upstream kernel. Besides of that, the hardware
>>>>>> is
>>>>>> useable (the usual auto-power-on-patch is required as well, but
>>>>>> that's
>>>>>> just a few days for doing it mechanically). However, currently with
>>>>>> only the factory kernel (which doesn't meet my definition of useable,
>>>>>> and I think also not yours). I suspect that I'm just a few pitfalls
>>>>>> away from getting this done, but nothing I could put say "takes this
>>>>>> many days". I'm also just trying since Saturday, so in the very early
>>>>>> stages and in discussion with upstream and vendor.
>>>>> I am surprised to read that a working kernel for 3A will be an issue.
>>>>> Any
>>>>> question
>>>>> you can contact chenhc@lemote.com. He is maintaining our kernel and
>>>>> trying
>>>>> hard to push patches upstream.
>>>>> Regards
>>>> It is indeed an issue, and is the most blocking one. We have contacted
>>>> chenhc and we tried to merge those patches to mainline, but resulting
>>>> to a non-bootable kernel. The latest working kernel is Linux 3.6 based
>>>> on his branch, while 3D acceleration does not work like in Lemote's
>>>> 3.5 kernel.
>>> Really? I remember that you have a good kernel with the 3.9 branch in
>>> dev.lemote.com.
>> Unfortunately it does not boot, and it may caused by the difficulty of
>> handling massive merge conflicts with 3.9 version of Debian kernel.
>> The merge was success on 3.6 branch so we are running on it.
> Which compiler do you use? 3.9 is OK here.

We've tried with 4.7.2-5 natively, and 4.7.2-22, 4.8.0-2 using
cross-build. Neither of them produced a working image. This does not
mean the tree you provided is not working, and could be related to our
merging with Debian tree where there are a few other patches.


Reply to: