[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fuloong Mini - netboot register dump

On Fri, Dec 14, 2012 at 10:49:52AM +0800, Fuxin Zhang wrote:
> 于 2012/12/14 0:46, Roland Kammerer 写道:
> >Hello guys,
> >
> >I tried to install debian with the daily image of today[1] on my Fuloong
> >Mini, but the install failed.
> >
> >I did the following:
> >*) put the three files on an ext2 formatted usb stick
> >*) boot to pmon
> >*) bl -d ide (usb0,0)/boot.cfg # and select d-i boot from the menu
> >
> >I also tried to manually load the kernel and initrd with the same
> >result:
> >
> >Both methods (manually and "bl") load the kernel and the initrd fine,
> >but after that I just get the register dump.
> BTW:“bl" should be "al" --> auto load?

not sure about that. I used "bl" and at least that part worked. I found
the "bl" version here on the yeeloong wiki page (
http://wiki.debian.org/DebianYeeloong/HowTo/Install ). "al" leads to
"command not found".

> A register dump normally means early kernel panic(before the
> framebuffer console is initialized and used),
> are you sure the kernel is ok?

It isn't a register dump from the kernel, sorry I should have made that
clear. It is that kind of register dump that comes from pmon/the
fuloong. That is even before the kernel kicks in. If I load "vmlinux"
and "initrd.gz" manually, it is that kind of dump that happens right
after I press "g". Definitely not a kernel dump.

Regards, rck

Reply to: