[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fuloong Mini - netboot register dump


On Thu, Dec 13, 2012 at 05:46:47PM +0100, Roland Kammerer wrote:
> I tried to install debian with the daily image of today[1] on my Fuloong
> Mini, but the install failed.
> I did the following:
> *) put the three files on an ext2 formatted usb stick
> *) boot to pmon
> *) bl -d ide (usb0,0)/boot.cfg # and select d-i boot from the menu
> I also tried to manually load the kernel and initrd with the same
> result:
> Both methods (manually and "bl") load the kernel and the initrd fine,
> but after that I just get the register dump.
> The hardware should be okay, OpenBSD works fine.
> Any hints? Do you need any further information? (output of "env")? Do I
> have to unset pmon's "bsd" variable or somethink like that?

On my Fuloong Mini, PMON limits initrd size to some small size (I don't
remember details, you should be able to check it from Lemote's GIT -
PMON repository has tags corresponding to the version string).

If you load too big initrd the boot will crash thanks to some conflicting
addresses. You can check this by just loading the kernel alone and
booting it and checking the console messages. The kernel should boot fine,
but eventually panic due to missing initrd.

As a workaround you can recompile a kernel+initrd into a single image.
In theory you could also fix and upgrade PMON or use GRUB, but I haven't
tried this so I cannot recommend it.


Reply to: