[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unable to tftp to Indy

Hi folks,

Apologies if I'm asking a common question, but I have googled myself
stupid on this and can't find any documentation that directly addresses
what I'm seeing happen here - at least, not in a way that makes sense to

I have two Indys: one is an R4600SC, the other is an R4600/133.  Both
have 64MB of RAM and 2GB (blank, recycled from working stock) HDDs; hinv
and printenv confirm this.  Both also have the same problem: neither one can
grab the tftpboot.img boot image from the tftp server I have connected
directly to the box via a crossover cable.  I can grab the image just
fine from other (non-SGI) machines via tftp, so tftpd is starting and
working as expected; the same goes for dhcpd (ISC DHCPD 2.0pl5).

In frustration, I rolled back to a 2.2.19-based distribution (Slack 8.0)
on the tftp server due to known issues with 2.4-series kernels and
booting Indys.  Nada.  Same error message:

	>> bootp()/tftproot/tftpboot.img
	No server for /tftproot/tftpboot.img.
	Your netaddr environment variable may be set incorrectly, or
	the net may be too busy for a connection to be made.
	Unable to execute bootp()/tftproot/tftpboot.img

This happens on both Indys, and with various permutations of the bootp()
command (e.g., boot -f bootp()  The
dhcpd is ISC DHCPD 2.0pl5, and it appears to be working as expected.
I've tried with netaddr set to a valid IP for the network the server is
on, with netaddr unset, with DHCP both enabled and disabled and...
Nothing.  Always the same error message.

Again, apologies if this is a common question, but I would really
appreciate any assistance any is able to give as I am new to running
Linux on mips and need to get this thing going ASAP.


- Cameron.

Reply to: