[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem installing woody on an Indigo2

On Thu, Nov 08, 2001 at 10:28:22AM +0000, Mat Withers wrote:
> Guido Guenther (agx@sigxcpu.org) wrote:
> > On Wed, Nov 07, 2001 at 05:01:12PM +0000, Mat Withers wrote:
> > > I'm attempting to install debian woody on a SGI Indigo 2 and am running up against a problem half way through the install. I'm using a serial console (which works fine) and booting kernel-image-2.4.3-ip22-r4k via bootp/tftp.
> > Could you try a more recent kernel?
> > You can just use
> >  ftp://ftp.debian.org/debian/dists/woody/main/disks-mips/3.0.15-2001-10-19/r4k-ip22/tftpboot.img
> >  since it is kernel 2.4.9+initrd, so you don't need a nfs-server.
> This may sound a bit stupid - but what to I need to supply to the kernel on the command line to mount the initrd contained in this image as root ? I've tried various root= and initrd= settings and can't seem to mount it.
Use "bootp(): root=/dev/ram0" in the prom.

> I've tried the above kernel and my existing nfs root and I still get the same problem.
> > > 
> > > I'm then  mounting install root 3.0.15 via nfs and then going through the installation proces. The problem comes when installing the base system (using 'network' as a source). The installer downloads about 3/4 of the packages and then stops with the error "Couldn't download modutils". 
> > Are there any more detailed error messages on tty3 or tty4?
> Again - maybe I'm being a bit dumb - but how do I get to see output to tty3 and tty4 on a serial console ? vc's are disabled to I can't just <alt> f-key between them.
My braino, sorry. Could you have look in the logs(/var/log/) then?
 -- Guido

Reply to: