[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#660162: RFS: tack/1.07-2

To be pedantically correct, build-dependency on autotools-dev should be bumped to >= 20110508.1, as this version introduced the dh addon. (I said “pedantically”, because a sufficient version is already in stable.)

Could you regenerate autotools stuff at build time? autoconf-dickey is now in the archive, so this should be feasible. (If you feel adventurous, you could try also with GNU autoconf.)

As far[0] as I can see, your debian/rules doesn't honour DEB_BUILD_OPTIONS=noopt. You might want to acquire “correct” {C,CPP,LD}FLAGS from dpkg-buildflags (enabling hardening as a side-effect).

[0] Not very far, I didn't try to build the package yet. :P

Jakub Wilk

Reply to: