[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: alien-arena (updated package)

On Mon, 18 Jan 2010 22:56:37 +0100 Patrick Matthäi wrote:

> Hash: SHA1
> Michael Gilbert schrieb:
> > On Mon, 18 Jan 2010 21:34:49 +0100 Patrick Matthäi wrote:
> >> In general it looks good, but you have missed one important thing, if
> >> you split up packages: conflicts and replaces.
> >>
> >> Now, if users upgrade from 7.0 to 7.33, dpkg would abort, because the
> >> - -common package include files, which are also present in the
> >> - -client/-server package.
> >> So you have to define replaces and conflicts in debian/control.
> > 
> > I have a solution, which I think solves this problem, but I'm not sure
> > how to test whether to test the it gets resolved correctly with apt.
> > Any suggestions on how to do that?
> Without checking your solution now (out of time for today), have a look
> at the geoip package for example. Have a look at the debian/control and
> the changelog, why those fields are added.

I think I have a working solution, which is up on mentors now.
I'm able to start from all 7.0 packages, then using

  dpkg -i alien-arena_7.33*.deb alien-arena-data_7.33*.deb

does a successful upgrade.  It only required a 'Replaces: alien-arena'
in alien-arena-common's part of the control file.  Please review.


Reply to: