[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: versioned Build-Depends on debhelper

Le Wednesday 30 July 2008 23:57:44 Marc Haber, vous avez écrit :
> On Wed, Jul 30, 2008 at 02:14:53PM -0700, Russ Allbery wrote:
> > Stanislav Maslovski <stanislav.maslovski@gmail.com> writes:
> > > My sponsor asked me to delete versioned build dependency on debhelper.
> >
> > I think this is bad advice.
> I agree. There are people building Debian packages on older releases,
> and having a package fail because a known versioned dependency had its
> version removed it a disservice to those people.
> I might be missing arguments for removing the version, but I have only
> been a DD for like seven years.

Well, while I wouldn't ask to remove a versioned build-dep,
you could also argue with your reasoning that all build-dep
should be versioned..

I think a relatively safe requirement is to version if it needs more than
the current stable (or perhaps oldstable) version.

I've got to get away from here
This is not a place for me to stay
I've got to take my family
We'll find a quiet place

Reply to: