[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: grun -- GTK based Run dialog [delayed-7 NMU]



On Mon, Oct 15, 2007 at 10:20:06AM -0500, Luis Rodrigo Gallardo Cruz wrote:
> Bas Wijnen <wijnen@debian.org> writes:
> >  I have just one question about this part:
> >
> > @@ -40,6 +40,7 @@
> >  #include "grun2.xpm"
> >  #if defined (HAVE_GETTEXT) || defined (HAVE_CATGETS)
> >  #include <libintl.h>
> > +#define UTF8 "UTF-8"
> >  #else
> >  #include "intl/libintl.h"
> >  #endif
> > @@ -1107,6 +1108,7 @@ int PASCAL WinMain(HINSTANCE hInst, HINS
> >  #ifndef WIN32
> >         setlocale (LC_ALL, "");
> >         bindtextdomain (PACKAGE, LOCALEDIR);
> > +       bind_textdomain_codeset (PACKAGE, UTF8);
> >         textdomain (PACKAGE);
> >  #endif /* WIN32 */
> >
> > Why do you need to #define this? 
> 
> Just because I dislike using magic constants. When I started writing
> the patch I expected having to use it in more than one place. Then it
> turned out there was no need, but I didn't think to change it.

Ok.  In that case it should be outside the #ifdef, so it is also defined

> > when intl/libintl.h is included? 

But looking at the rest of the code, I would just use the string literal
directly.  I agree with you that a define would be nicer, but it's not
how the rest of the code is done, and NMUs should be in the style of the
original as much as possible.

Is it ok with you if I upload it with a string literal instead of a
define?

Thanks,
Bas

-- 
I encourage people to send encrypted e-mail (see http://www.gnupg.org).
If you have problems reading my e-mail, use a better reader.
Please send the central message of e-mails as plain text
   in the message body, not as HTML and definitely not as MS Word.
Please do not use the MS Word format for attachments either.
For more information, see http://pcbcn10.phys.rug.nl/e-mail.html

Attachment: signature.asc
Description: Digital signature


Reply to: