[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: grun -- GTK based Run dialog [delayed-7 NMU]



Bas Wijnen <wijnen@debian.org> writes:
>  I have just one question about this part:
>
> @@ -40,6 +40,7 @@
>  #include "grun2.xpm"
>  #if defined (HAVE_GETTEXT) || defined (HAVE_CATGETS)
>  #include <libintl.h>
> +#define UTF8 "UTF-8"
>  #else
>  #include "intl/libintl.h"
>  #endif
> @@ -1107,6 +1108,7 @@ int PASCAL WinMain(HINSTANCE hInst, HINS
>  #ifndef WIN32
>         setlocale (LC_ALL, "");
>         bindtextdomain (PACKAGE, LOCALEDIR);
> +       bind_textdomain_codeset (PACKAGE, UTF8);
>         textdomain (PACKAGE);
>  #endif /* WIN32 */
>
> Why do you need to #define this? 

Just because I dislike using magic constants. When I started writing
the patch I expected having to use it in more than one place. Then it
turned out there was no need, but I didn't think to change it.

> Does it also work when intl/libintl.h
> is included? 

No idea :(

Attachment: pgpkSHUaU74nG.pgp
Description: PGP signature


Reply to: