[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: include in mentors faq? Re: DFSG compliant packages (Solution)

Justin Pryzby <justinpryzby@users.sourceforge.net> writes:

>> >> 	Another one, it depends on some tools, like rpm2cpio to updated
>> >> properly. Should those tools be included as a dependecies on the control

> and

>           The `Depends' field should also be used if the `postinst',
>           `prerm' or `postrm' scripts require the package to be present in
>           order to run.  Note, however, that the `postrm' cannot rely on
>           any non-essential packages to be present during the `purge'
>           phase.

> Upgrading is typically in the postinst.  Or did I misunderstand?

I'm pretty sure that he's talking about updating the .orig.tar.gz tarball,
and the script that was upthread called rpm2cpio as part of that.

Russ Allbery (rra@stanford.edu)             <http://www.eyrie.org/~eagle/>

Reply to: