[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: autopkgtest regression: Segmentation fault

Dear Mattia and Paul,

On 16/11/2018 11:08, Mattia Rizzolo wrote:
On Fri, Nov 16, 2018 at 07:28:21AM +0100, Emmanuel Promayon wrote:
Thanks to the (great work) of Gert  on vtk7 and gdcm packages, version
7.1.1+dfsg1-9 of vtk7 and version 2.8.8-2 of gdcm are now both in testing.
I sent a retry request for the autopkgtest of camitk version 4.1.2-2 but it
naturally failed as camitk 4.1.2-2 was built with the problematic version of
gdcm (error was at run time: "libvtkRenderingFreeTypeFontConfig-7.1.so.7.1:
cannot open shared object file: No such file or directory").
This is the signature of an ABI break not correctly handled.

Thank you Mattia for your answer.

From what I can understand, this autopkgtest regresion (bug #911793) originated in a dependency mismatch in gdcm (when gdcm 2.8.7-2 moved its dependency from python2 to python3 and consequently from vtk6 to vtk7), see my explanation tentative [1].

The current binary version of camitk was compiled with gdcm 2.8.7-5  [2]. This is the reason why I initially asked for a rebuild as there was a temporary mixup in vtk7/gdcm dependency and I supposed that now with gdcm 2.8.8-2 in testing, the dependency problem should be solved.

That's not the right action to take (or better, not only).  That
situation must not happen, so most likely some versioned dependency or
versioned break was missed somewhere.  Maybe Paul has more insight on
the problem (I just read this single email and wanted to block a
"simple" rebuild)

Thanks to Paul for his answer. Mattia you can find Paul's initial answer about this is in the bug tracker [3].

In the meanwhile I tried to rebuild the camitk package locally (on last Friday), and autopkgtest ran with no error.
Unfortunately, this is not the case anymore!
Since yesterday I cannot rebuild the package anymore. There is a "pbuilder-satisfydepends failed." error due to hdf5:
> The following packages have unmet dependencies:
> libhdf5-103 : Conflicts: libhdf5-100 but 1.10.0-patch1+docs-4+b2 is to be installed
> libhdf5-cpp-103 : Conflicts: libhdf5-cpp-100 but 1.10.0-patch1+docs-4+b2 is to be installed
> libhdf5-openmpi-103 : Conflicts: libhdf5-openmpi-100 but 1.10.0-patch1+docs-4+b2 is to be installed
> Unable to resolve dependencies!  Giving up...

It seems camitk-4.1.2-2 is not very lucky!
The current deadline for camitk package removal is 22 November.

What do you think is the best course of action?

Thanks again for your help (and sorry about my newbie statements!)


[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911793#10
[2] https://buildd.debian.org/status/fetch.php?pkg=camitk&arch=amd64&ver=4.1.2-2&stamp=1540312520&raw=0
[3] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911793#15

Reply to: