[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unattended upgrades don't work in wheezy

On 04.07.17 10:38, Antoine Beaupré wrote:
Adding the bug in CC.

so am I.

On Tue, Jul 4, 2017 at 10:02 PM, Matus UHLAR wrote:
I just found out that the unattended-upgrades package in wheezy does not
upgrade packages although configured to do it.

On 2017-07-04 22:13:44, Paul Wise wrote:
I note that this same situation will apply to jessie when it becomes

I haven't tested the default stretch sources.list and u-u configuration.

This is a recurring problem, but I think it was fixed in more recent
releases (e.g. jessie). It was reported in #762965 before and I believe
those bugs may need to be merged.

I didn't feel that to be the same problem, because its submitter changed
configuration manually (different behaviour can be expected in such case).
u-u worked well with default 50unattended-upgrades on wheezy machines,
until stretch release 3 weeks ago.

I can at least say it seems to be fixed in stretch. This is my stretch
system's default u-u config:


It seems we should be using the codename there ("wheezy") and not the
archive name ("oldstable") as the latter has the risk of doing
unexpected major updates, although I suspect u-u may have built-in
protections against this.

I believe it has. This is however a problem of sources-list configuration,
not u-u itself.

Therefore when we fix this, we should use codename, if that's supported
in wheezy. There were issues with codename matching, however (#704087)
which may make that impossible, so we may be forced to do the
"oldoldstable" trick...

I have tried it and unfortunately it does not work. We apparently need the
oldoldstable trick...

Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
WinError #98652: Operation completed successfully.

Reply to: