[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: live-build 3.x summary of top 3 issues this week

Thank you very much for this interesting and helpful summary Ben.

Am 08.10.2012 23:06, schrieb Ben Armstrong:
Dear users of live-build 3.x,

Please always check latest status on the debian-live list, as both the
wheezy and sid are moving targets. That means both the debian-live
software itself and the archives are constantly changing, so builds that
worked yesterday might not work today and vice-versa.

That being said, since I seem to spend a lot of my time when I help
users addressing the same issues, I thought I'd take some extra time
this Canadian Thanksgiving holiday to give you a brief summary of the
top 3 issues raised within the past week or so. This will save me as
much time as it will save you. ;)

Thanks for using debian-live. As always, if you encounter new issues,
please read and follow the Bugs section of the manual:


It will save us a lot of time if you read the chapter carefully and
follow the advice within.
I have just read this chapter again (and followed steps inside).

And now, the top 3:

1. Most users will be building wheezy images (the default for 3.x). The
versions of live-boot and live-config in wheezy now lag considerably
behind because we're in a freeze, meaning several issues have already
been fixed. Once we're certain the new versions will be acceptable to
the release team, we'll request unblock requests for them.
Meanwhile, we suggest you use the sid versions via this recipe in the
APT pinning section of live-manual:


2. The handling of 'lb config --initramfs auto' (the default) was broken
in live-build and was just discovered and fixed a short while ago with
the upload of live-build 3.0~a65-1. Sorry, I don't know in which release
this bug was introduced. Until it hits your mirror you can also find it at:


3. The linux-image-flavour metapackages in sid up until a very short
while ago were out of sync with wheezy (i.e. point at the old abi# "3"
instead of the new one "4". This happens from time to time. When it
does, this can be worked around by ignoring those metapackages and
specifying the package name stub for the kernel as in:

lb config --distribution sid --linux-images linux-image-3.2.0-4
I didn't find the "--linux-images " option in the code (and I have got an error message when trying to use it).
A similar named option I have found was --linux-packages

By the time you read this, the new metapackages should be at your
mirror, so sid builds will no longer have this problem and the
workaround will no longer be needed.
I have tested yesterday and today a65. It looks like there is still this "out of sync" bug in sid (details below). After getting sure what is wrong I would raport a bug on the appropriate debian or kernel list (I am not sure if it is still the "out of sync" bug in sid or maybe something else).

root@sid:/tmp/live/sid# dpkg -l | sed -n '/[^x]live-[^m]/s/  *all.*$//p'
ii  live-boot                             3.0~b6-1
ii  live-boot-initramfs-tools             3.0~b6-1
ii  live-build                            3.0~a65-1
ii  live-config                           3.0.8-1
ii  live-config-sysvinit                  3.0.8-1

root@sid:/tmp/live/sid# dpkg -l | sed -n '/bootstrap/s/  *all.*$//p'
ii  debootstrap                           1.0.42

root@sid:/tmp/live/sid# uname -a
Linux sid 3.2.0-3-amd64 #1 SMP Mon Jul 23 02:45:17 UTC 2012 x86_64 GNU/Linux

# ------------------------------------------------------------------------------
# boot menu of the created live image:

linux: 3.2.30-1

live-build                            3.0~a65-1
live-boot                             3.0~b6-1
live-config                           3.0.8-1
live-tools                            3.0.12-1

# some boot error messages:
Loading, please wait...
/init: .: line 220: can't open '/scripts/live'
[    3.216819] Kernel panic - not syncing: Attempted to kill init!
[    3.216889] Pid: 1, comm: init Not tainted 3.2.0-4-amd64 #1 Debian 3.2.30-1
[    3.216960] Call Trace:
[    3.217016]  [<ffffffff81345295>] ? panic+0x95/0x1a5
[    3.217082]  [<ffffffff81049a77>] ? do_exit+0x95/0x6fc

The system hangs (doesn't react on any kyeboard entries, even Ctrl-Alt-Del)

# ------------------------------------------------------------------------------

# Tested configurations (auto/config)

set -e

lb config noauto --clean --mode debian --bootloader syslinux --architectures amd64 \
          --debug --parent-distribution sid --parent-debian-installer-distribution sid \
          --distribution sid --debian-installer live --debian-installer-distribution sid \
          --binary-images iso-hybrid --chroot-filesystem squashfs "${@}"

I have also the binary.log in case you would like to look inside (I run lb build with the *--debug* option)

It would be helpful for me if someone else could confirm the same issue on sid. Thank you in advance.

regards, Mark


Reply to: