[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

/live_media not mounted after 2nd reboot with 'persistent'



I have created another a Debian live system on a USB stick with the help of 
the make-live from live-helper_1.0~a9-1 and I tested it again. It seems that 
after a 2nd reboot from the USB stick with the 'persistent' 
option /live_media wont't be correctly mounted anymore.

Here is what I did:

1) Booting up with 'live persistent quickreboot' works as 
expected, /live_media is mounted from /dev/sda1 as rw.
I then created some files in the home directory (/home/usblive in my case), so 
as to verify that it would become really persistent after a later reboot.

2) Then I did a snapshot and saved it on the USB stick's partition:
	sudo casper-snapshot --type=squashfs
	sudo cp /mnt/casper-snapshot/*  /live_media
	umount /mnt/casper-snapshot

3) To be followed by a reboot:
	sudo reboot

4) And I started it again with:
	live persistent quickreboot

This time it only sees an empty /live_media directory, even though a
	cat /proc/mounts
shows this:

	rootfs / rootfs rw 0 0
	none /sys sysfs rw,nosuid,nodev,noexec 0 0
	none /proc proc rw,nosuid,nodev,noexec 0 0
	udev /dev tmpfs rw 0 0
	/dev/sda1 /live_media vfat 
rw,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1 0 0
	/dev/loop0 /filesystem.squashfs squashfs ro 0 0
	tmpfs /cow tmpfs rw 0 0
	unionfs / unionfs 
rw,dirs=/cow=rw:/filesystem.squashfs=ro,debug=4294967295,delete=whiteout 0 0
	tmpfs /cow tmpfs rw 0 0
	unionfs /dev/.static/dev unionfs 
rw,dirs=/cow=rw:/filesystem.squashfs=ro,debug=4294967295,delete=whiteout 0 0
	tmpfs /lib/init/rw tmpfs rw,nosuid 0 0
	usbfs /proc/bus/usb usbfs rw,nosuid,nodev,noexec 0 0
	tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
	devpts /dev/pts devpts rw,nosuid,noexec 0 0


Is this a bug, or has the /live_media become non-visible on purpose?

Juergen Neuhoff


Reply to: