[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PCMCIA Does Not Work Dell Latitude C510/C610 with Lenny

Hi John,

On Tue, Mar 16, 2010 at 09:05:51AM -0600, John Medrano wrote:
> I am currently running Lenny on a Dell C510/C610 laptop.

Which specific laptop?  AFAICT, the C510 has a Celeron processor, while
the C610 has a Pentium III.

> When I insert a wireless PCMCIA card into the unit nothing happens.

Some details concerning the problem PCMCIA device (e.g. brand, model and
revision/version if known) would be useful.  Is this a 16-bit or 32-bit
(CardBus) device?

> I issue the command:  pccardctl status    and it indicates that no
> cards are inserted. lspci does not see the card.

For your information, lspci does not display details of 16-bit PCMCIA
devices.  Is the yenta_socket module loaded? (lsmod | grep yenta).  Use
the modprobe command to insert it if not listed.

Have you tried both PC Card slots?  Are other PCMCIA devices, if
available, detected and operable on your system?

> I tried various versions of the kernel, cheat codes such as
> pci=assign-busses ..., and nothing.

The output returned for the 'uname -r' command would be useful.


Reply to: