[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PCMCIA Does Not Work Dell Latitude C510/C610 with Lenny

Thank you for your response Geoff.

The laptop is a C610 with a Pentium III.

The card that I am trying to use is a Belkin N Wireless Notebook Card.
 Part No. F5D8013. Ralink RT2860 driver.  This same card worked on
another labtop running Knoppix with 2.6.32 kernel. I tried Knoppix on
this machine and it still did not see the card.

I have tried to use the card in both slots and had the same result.
The card worked when windows was installed in the unit. Unfortunately
I do not have any other PCMCIA devices that I could try.

uname -a returns  Linux debian 2.6.26-2-686 #1 SMP Tue Mar 9 17:35:51
UTC 2010 i686 GNU/Linux

The yenta_socket module is loaded. This machine is a little older,
should I use i82365? I tried modprobe i82365 but it could not find the

lspci shows the cardbus chipset as:

00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 02)
00:01.0 PCI bridge: Intel Corporation 82830 830 Chipset AGP Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 41)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM
AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
02:01.0 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
02:01.1 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller

Please advise on how I can continue.

Thanks again,

Hi John,

On Tue, Mar 16, 2010 at 09:05:51AM -0600, John Medrano wrote:
> I am currently running Lenny on a Dell C510/C610 laptop.

Which specific laptop?  AFAICT, the C510 has a Celeron processor, while

the C610 has a Pentium III.

> When I insert a wireless PCMCIA card into the unit nothing happens.

Some details concerning the problem PCMCIA device (e.g. brand, model and
revision/version if known) would be useful.  Is this a 16-bit or 32-bit

(CardBus) device?

> I issue the command:  pccardctl status    and it indicates that no
> cards are inserted. lspci does not see the card.

For your information, lspci does not display details of 16-bit PCMCIA

devices.  Is the yenta_socket module loaded? (lsmod | grep yenta).  Use
the modprobe command to insert it if not listed.

Have you tried both PC Card slots?  Are other PCMCIA devices, if
available, detected and operable on your system?

> I tried various versions of the kernel, cheat codes such as
> pci=assign-busses ..., and nothing.

The output returned for the 'uname -r' command would be useful.


Reply to: