[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Laptop sound keys not working properly

Problem solved!
I didn't know how to set those mapping, so I googled for "gnome shortcuts sound" and found this post: http://ubuntuforums.org/showpost.php?p=4134303&postcount=5

I did what that person said and it worked. More specifically, that listbox - which I thought was just listing my available device options - actually defines the default mixer. Mine had "beep" selected. I changed to "master" and it instantly started working ok again.

Screenshot: http://img710.imageshack.us/img710/1023/somgnome.png

Thank you.

2010/2/2 António PT <acmps.pt@gmail.com>
try setting the volume up & down keys to these commands:

"amixer set Master 5%+" for volume up
"amixer set Master 5%-" for volume down

2010/2/1 Otto <ottoteixeira@ig.com.br>

I added myself to the missing groups: dip, powerdev, users and scanner. fuse doesn't exist.
Nothing changed.

I checked the shortcut keys and they're ok.

Isn't there a way I can see what is going on after the volume window pops up? If it's sending the correct info to the mixer?


2010/2/1 Otto <ottoteixeira@ig.com.br>

I'll try that when I get home, but it doesn't seem it will help. The other keys (like screen brightness) still work. Even sound keys work (showing volume window), that just don't have any effect. Doesn't look like a shortcut problem.

But I'll try and return here a few hours later. Thanks.

2010/2/1 António PT <acmps.pt@gmail.com>

Try adding these groups: dialout cdrom floppy audio dip video plugdev users scanner netdev powerdev fuse

The groups from the person who you asked them might not have the group responsable for keys.

If that doesn't work, try modifying the settings in System > Preferences > ... something keyboard shortcuts ... (sorry I'm a KDE user, former Gnome user).


2010/1/31 Otto <ottoteixeira@ig.com.br>

I had Debian Lenny working 100% with my Lenovo 3000 N200 laptop. All keys working flawlessly.

Then I accidentally removed myself from all groups with usermod. To fix things (like having no sound, since I removed myself from audio group) I asked someone which groups he was part of and then added myself to them.

I now have audio back, but the sound keys are not working as expected. They even popup up volume control window and the volume bar moves, but that has no effect. It's like if that window is associated with a different mixer.

alsamixer works and so does Gnome's sound applet.
I want to make them work back as they were before I messed my groups.


Attachment: som-gnome.png
Description: PNG image

Reply to: