[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Suspend stopped working on T60

On Sat, Sep 01, 2007 at 01:47:19PM -0600, Bob Proulx wrote:
> Niklas Rehfeld wrote:
> > Jesse Sheidlower wrote:
> > > This morning, I tried to do this and it didn't work; it locked the
> > > screensaver, but did not suspend.
> Did the problem repeate or was this a one time problem?

The problem has continued; since its initial appearance I
have been unable to suspend.

> > I had a similar problem, after I upgraded the kernel after a
> > security release in the repos, and had to install the graphics
> > driver modules again (I don't know what graphics card the T60
> > has). then it all worked fine for me again.
> I think you have identified the problem.  When new kernels are
> installed it will not be possible to resume across them.  The recent
> Linux kernel security update should have been installed and if so then
> the running image would not be able to resume after a suspend.

This may apply to him, but I still cannot suspend even after rebooting,
so there's no chance that it's a conflict with the running kernel.

I'm not using the fglrx driver, by the way; I'm using whatever
default configuration xorg loaded--this worked fine out of the box
and I didn't see any need to change it. I did try reinstalling
the video drivers anyway, but still without any luck. I guess I
might try to start using the fglrx driver, though I'm a little
worried about messing up X.

Thanks for any thoughts....By the way, I got a personal e-mail
pointing me to a discussion of this on a Ubuntu forum, where a
poster suggested unloading the cpufreq utility (and then reloading
it on resume), but this also didn't work.

Jesse Sheidlower

Reply to: