[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE not responding to mouse clicks after a resume-from-ram

Ian Greenhoe wrote:
Are you using hibernate from the hibernate package? If so, then there
are some things that you can do to help the below.
...after about 3 or 4 sleep/resume cycles, the kbluetoothd stops recognizing any bluetooth adaptor ...

Try stopping kbluetoothd, unloading and reloading your kernel bluetooth
modules, and starting kbluetoothd. This may or may not work; I know of
some hardware that this is necessary for. i.e. the ipw2200 wireless
chipset. :P
Uhhh.. that would be me (the ipw2200, that is). :)

I think I tried this a couple of times before. As I recall, it made the problem even worse (although going from "not working" to "still not working" isn't necessarily worse, I mean "worse" in that, upon reloading the bluetooth drivers, the no longer saw any BT hardware... either that or kbluetoothd saw even less of the kernel BT services). I'll try it next time it flips out and make a note of exactly what happens.
If stopping/reloading/starting as above works, you will probably need to
add stopping kbluetoothd and unloading the modules on hibernate, and
loading the modules and starting kbluetoothd.
When this first happened, I tried adding
 OnSuspend 20 /etc/init.d/bluetooth stop
 OnResume 20 /etc/init.d/bluetooth start

to /etc/hibernate/common.conf and that really pissed off kbluetoothd. I guess I could also kill kbluetoothd upon hibernate, but I was just hoping that there was an easier way to fix all of this before I went down that road. I'm pretty sure that I came across something in hibernate's conf that basically says "upon resume, start this... but only if you killed it before a sleep". I'll have to track that command down again.
... and after about 15 or so sleep/resume cycles, KDE stops responding to mouse-clicks. I can move the mouse cursor all over the screen... and I can switch to a text console and back to KDE, etc... but clicking doesn't do anything. I can't close windows, I can't move them, I can't launch anything with kicker, etc.

Try hibernating again. I've found that on the rare times when my mouse
stops responding that suspending and resuming again helps.
Okay... I'll try that.

- Joe

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply to: