[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ieee80211 package not installable-- IT WORKS!! Thanks everyone

I seem to remember that ieee80211-source fell through a crack as far as module-assistant was concerned around the time Sarge went stable; all fixed in Etch now, of course.

In my case I fixed it by manually adding the name of the package (ieee80211-source) to the list of packages in /usr/share/modass/compliant.list.

Give that a try; hope it works for you,

Thanks John, for the explanation about it being missing, which seems very weird. But I already did an apt-get source and it came right in, and somehow I ended up with all the ieee.. modules in lib/modules/drivers/net/wireless. Its been a learning experience.

So I did a modprobe and then iwlist scanning shows the interface!!

I really have no idea what happened: does apt-get source compile/install things?

The Netgear router is nicely viewable with a browser, so I just set /etc/network/interfaces to e.g.

auto eth1
  iface eth1 inet dhcp
  iface home inet dhcp
       wireless-essid wireless ID
       wireless-key key

And oh my oh my, it worked!!!

And NOW, time to go to bed!!

Thanks to debian-laptops, very happily to bed (if exhausted!)

David Riggs

What about WPA?? what /etc/network/interfaces file should contain?
I know that there exist soft "wpasupplicant" but it is a supplicant, and I don't want to use it. Is there any way to make it work without wpasupplicant?

Krzysztof Fabjański

Reply to: