[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

tapping disabled for touchpad under dell inspiron 600m

Hi !

After having a good experience with linux- under ibm t40, I
decided to use it under dell/inspiron 600m.

The problem I found is that the touchpad doesn't tap properly.  Under
linux-2.6.10 with same debian/unstable it does...

Somehow it's possible to single tap, but no way to reproduce the
tap...  double tap is not possible...  Annoying?

Any ways.  For linux-2.6.10 the touchpad is detected as follows (dmsg):

input: PS/2 Generic Mouse on isa0060/serio1

While for linux-

ALPS Touchpad (Glidepoint) detected
Disabling hardware tapping
input:  Alps PS/2 ALPS Touchpad on isa0060/serio1

In both cases the touchpad is detected on isa0060,  but in the latest
case as a touchpad and in the erliest as a generic ps/2 device.  For
the latest case it doesn't work, but for the earliest it does...

I searched the web but I got really confused...

1)  It looks like the touchpad is the one detected on linux- 
Can some one confirm if right?  I mean, I tried to find description
from dell but didn't find it, so I'm not 100% sure...

2)  If the touchpad is not detected correctly  by linux-, then
there might be a bug in the kernel but I haven't read aobut it.  I
really doubt this is the case.  But I'm not sure.  Can some one

3)  If touchpad is detected correctly by linux-, then I've
read about a lot of stuff on the web.  There are several description
for fixes, but all of them point to a kernel bug.  I didn't file the
bug filed against any kernel though.  The only filed bug is under
red-hat:  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=153201.
 The only fix that sounds to solve the problem is provided by a
red-hat guy:  https://www.redhat.com/archives/fedora-devel-list/2005-March/msg00304.html.
 Now I'm not sure here.  Has someone tried the previous patch?  I
looked at recently change_log, and noting shows up there
fixing this.  Is the bug existant under the kernel archives?  Is it
planned to be solved?  Has some one successfully tried it?

4)  There's a mention of the Synaptics touch pad driver at: 
http://web.telia.com/~u89404340/touchpad.  However it looks like it
still have problems for 2.6.11 kernels and patches are required still.
 Any one has tried this synaptics driver under kernel or
later succesfully?  Any patches applied?

OK, it was long, but I have only doubts...  So far I'm sticking to
2.6.10 kernel, however I'm afraid mechanism for the touchpad is going
to change any ways....  Maybe I'll have to wait for later kernel for
getting this working just under kernel (no synaptics driver).  If so,
has any one any idea of when is it planned to introduce the fix?  I
read change_log for, and the fix seems not to be there, and I
also read change_log for 2.6.12-rc4, and there's no reference to this
problem there either...

Thanks a lot in advance,

Javier-Elias Vasquez-Vivas

Reply to: