[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem getting my Crystal 4237b sound card to work

Op do 30-12-2004, om 21:53 schreef Alexander Toresson:
>> then had to configure. Isn't alsa built into the kernel 2.6 and later?
>The drivers are part of the kernel, the tools (configuration tools,
>players etc.) are not.
>> I then tried to use modprobe to install the drivers. Didn't work.
>> Output of "modprobe snd-cs4236":
>> CS4236+ soundcard not found or device busy
>> FATAL: Error inserting snd_cs4236
>> (/lib/modules/2.6.8-1-686/kernel/sound/isa/cs423x/snd-cs4236.ko): No
>> such device
>> FATAL: Error running install command for snd_cs4236
>What did lsmod show? Maybe some other driver was already claiming the
>soundcard. If, during boot, it still loads the wrong driver, try the
>rename thing I mentioned earlier.
>You could try unloading all sound related modules that show up in the
>lsmod list, and then modprobe snd-cs4236 again.
>I haven't configured any ISA PnP cards lately, but maybe something like
>pnpdump or lspnp shows something useful. You might need to enter the
>right options when you modprobe snd-cs4236 (such as the port or IRQ),
>which is probably shown in the output of those commands.
>So, in short: First make sure that no other driver is in your way. Then
>try to get snd-cs4236 loaded by specifying the right options.

Since I installed alsa-utils, the cs4232 driver hasn't loaded at
startup. Instead, I get a message from alsa saying "no soundcard

lspnp outputs:

00 PNP0a03 PCI bus
01 PNP0c01 System board
02 PNP0c01 System board
03 PNP0000 AT programmable interrupt controller
04 PNP0100 AT system timer
05 PNP0200 AT DMA controller
06 PNP0303 IBM enhanced keyboard (101/102-key, PS/2 mouse support)
07 PNP0f13 PS/2 port for PS/2-style mice
08 PNP0800 AT-style speaker sound
09 PNP0b00 AT real-time clock
0a PNP0c04 Math coprocessor
0b PNP0e03 Intel 82365-compatible CardBus controller
0c PNP0501 16550A-compatible COM port
0d SMCf010 communications device: RS-232
0e PNP0401 ECP printer port
0f CSC0000 Crystal PnP audio system CODEC
10 CSC0010 Crystal PnP audio system control registers
11 PNP0700 PC standard floppy disk controller

lspnp -v 0f outputs:

0f CSC0000 Crystal PnP audio system CODEC
        io 0x0530-0x0537
        io 0x0388-0x038b
        io 0x0220-0x022f
        irq 5
        dma 1
        dma 0

lspnp -v 10 outputs:

10 CSC0010 Crystal PnP audio system control registers
        io 0x0210-0x0217

So my command should be:

modprobe snd-cs4236 port=0x530 cport=0x210 dma1=1 dma2=0

Fails with the same error as modprobe snd-cs4236.
I've tried unloading all snd-* modules and soundcore, got the same error.
I found a page where a a guy used this commandline to get the same
soundcard to work:

modprobe snd-cs4236 port=0x530 cport=0x210 isapnp=0 dma1=0 dma2=5

This fails too.

pnpdump didn't exist on my system.

Regards, Alexander Toresson

Reply to: