[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem getting my Crystal 4237b sound card to work

I tried running alsaconf, only to find out that it didn't exist on my
system. So I fired up aptitude to find it. It was a virtual package.
It took some time to understand that I couldn't install that virtual
package and that it was replaced by alsa-utils. So I downloaded it,
and to my surprise, it was depending on the package alsa-base, which I
then had to configure. Isn't alsa built into the kernel 2.6 and later?

Anyway, I chose to enable support for isa-pnp and all sound cards.
When I then tried to run alsaconf, it didn't find any pci card, so it
went over to trying to identify any isa card (the cs4237b is an isa
card). By some reason it couldn't identify mine. It kept telling me
"No legacy card found". It even didn't manage to find my opl3 synth or
sb8/16 card (emulated in the cs4237b)! I tried choosing that it should
search all possible irq and dma settings, with no result. I even tried
switching to maintenance mode, to make sure that no program was
affecting it.

I then tried to use modprobe to install the drivers. Didn't work.
Output of "modprobe snd-cs4236":

CS4236+ soundcard not found or device busy
FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1-686/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
FATAL: Error running install command for snd_cs4236

It gave this error in the main console (CTRL-ALT-F1), both runlevel 2
and maintenance mode. The first line didn't appear in aterm.

Any idea what the problem might be?

Anyway, thanks for replying! I got no reply from either
www.linuxquestions.org or linuxforum.com.

Regards, Alexander Toresson

---------- Original message ----------
From: Koen Vermeer <koen@qi.tnw.tudelft.nl>
Date: Thu, 30 Dec 2004 16:28:52 +0100
Subject: Re: Problem getting my Crystal 4237b sound card to work
To: Alexander Toresson <alexander.toresson@gmail.com>

Op do 30-12-2004, om 15:35 schreef Alexander Toresson:
> I've installed Debian GNU/Linux 3.1 Sarge on my laptop, a Dell
> Latitude CPi D300XT.
> I'm using kernel 2.6.8-1-686.
> Everything's working as is should, except the sound card and the cd-rom.
> Firstly I'm working on getting the sound card, which is a Crystal
> 4237b, to work.

The instruction you refer to is very old. For example, modules.conf
isn't used with 2.6 kernels anymore - it's now in modprobe.conf. Try
running alsaconf and select the 4236 driver. Check if the right module
is loaded (lsmod, look for the cs4236 driver). If not, try loading it
manually - modprobe cs4236 or modprobe snd-cs4236).

If you're sure cs4232 is not what you want and it keeps getting loaded
during the boot sequence (due to an error in some hardware probing
routine), just try to rename the cs4232 module (it should end on .ko, .o
is for older kernels) so it cannot be loaded anymore.

Not sure that this will solve your problems, but it may be a good start.


Reply to: