[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED] Re: ndiswrapper and wireless on Inspiron 5160 : installation and some questions

Okay, after installing ndiswrapper, the problem was I wasn't able to connect to the network. Theee sites help me:

So I:
1) Booted into linux and made sure ndiswrapper was loaded by "$> lsmod | grep ndis"

2) Did "ifconfig wlan0" to see the device was being seen.

3) Did "iwconfig wlan0" to see the device's status. The ap was 000..0, encryption was off, essid was off/any.

4) I made the wireless router open, no  encryption.

5) killed waproamd "/etc/init.d/waproamd stop" <-- not sure why, but it could have helped. not familiar with waproamd yet.

6) set up wlan0:
$> iwconfig wlan0 essid "ssid string here"
$> iwconfig wlan0 key open  <-- IIRC

7) Then did "iwconfig" and it was showing me the ap' hardware address.

8) Did "ifup wlan0" and it obtained an address from the DHCP server.

9) Switched off the wlan (ifdown wlan0), put encryption and restarted the router. Then did "rmmode ndiswrapper" which killed all the eaerlier setting and did "modprobe ndiswrapper" to get the card back.

10) Did the command as in (6) and also:
$> iwconfig wlan0 key open <keyhere>

11) Then did "ifconfig wlan0" and was able to get the ip address again.

Hopefully this help somebody else. If you have an questions or if you think I have missed something above (quite possible), feel free to ask. BTW, I am now using the 0.11 version of ndiswrapper source from their website.

Howeve, for some curious reason, "iwlist wlan0 scan" was showing the network I was in but the "Quality=0/100"! Not sure why.

BTW, right after this, I then continued on to help set up a DWL-G520 wireless PCI card on my friend's computer who is running FC2 kernel 2.6.8. It took some work since it's been some time since I played with RedHat's ifcfg-eth? scripts. We used madwifi to setup his wireless card. But in his case, "iwlist ath0 scan" showed distinct number in "Quality=65/96" or something like this for the same network I tested my laptop in using ndiswrapper. Now why would that be?


Apparently, _ntr_, on 23/10/04 19:18,typed:
Hello, I just installed a linksys on a desktop, I had got the same ipv6 problem... I'm not sure it is gonna work in your case, for I installed in Fedora (it was not my machine). So, I'll tell you what I did in Fedora and you put it in Debian (to make the translation, check http://www.gnoppix.org/pages/rute/node28.html)

I did not have to define an essid, it gets all automaticaly, BUT I had to create a ifcfg-wlan0 file in /etc/sysconfig/network-scripts. (neither of these exist in debian, but the page above will tell you where to put the info).

This file had:

I had already got everything from my access point. Then,

ifconfig wlan0 up


dhclient wlan0

this is where the file above comes to the scene. With that file, dhclient gets you an ipv4 address, otherwise you'll get that no ipv6 routers present error message.

hope I helped somehow... sorry, but I got no experience with wireless in debian.

Okay, that is all fine, or so it seems to me. Then I listed the
interfaces with iwconfig and it includes:
wlan0     IEEE 802.11g  ESSID:off/any
         Mode:Managed  Frequency:2.462 GHz  Access Point:
         Bit Rate:54 Mb/s   Tx-Power:25 dBm
         RTS thr:2347 B   Fragment thr:2346 B
         Encryption key:off
         Power Management:off
         Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:15   Missed beacon:0

So looks like the wireless card is being seen. I don't have a wireless
network here where I am trying to get the wireles card working, but I
sometimes see this:
#> iwlist wlan0 scan
wlan0     Scan completed :
         Cell 01 - Address: 00:02:6F:08:51:22
                   Protocol:IEEE 802.11b
                   Frequency:2.462 GHz (Channel 11)
                   Quality:0/100  Signal level:-86 dBm  Noise
level:-256 dBm
                   Encryption key:off
                   Bit Rate:1 Mb/s
                   Bit Rate:2 Mb/s
                   Bit Rate:5.5 Mb/s
                   Bit Rate:11 Mb/s

And dmesg says:
ndiswrapper version 0.11 loaded (preempt=yes,smp=yes)
ndiswrapper: using irq 18
wlan0: ndiswrapper ethernet device 00:0b:7d:08:25:9d using driver bcmwl5a
wlan0: encryption modes supported: WEP, WPA with TKIP, AES/CCMP
ndiswrapper: driver bcmwl5a (Broadcom,06/25/2004, added
ndiswrapper (iw_set_encr:685): key 1 is not set
wlan0: no IPv6 routers present

But I am not sure how to get the ESSID info into the card. I have tried
this in /etc/network/interfaces:
iface wlan0 inet dhcp
       name Wireless LAN card
       wireless_essid Sunny
       wireless_channel 6
       wireless_key 0a1b2c3d4e

But iwconfig still does not show the ESSID of "Sunny"? What am I missing

Reply to: