[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Synaptics Touchpad (again!...) X ok / console ko

Piero Furiesi wrote:
Hi all,

    I read all recent threads about Synaptics Touchpad (*), but I still have a little problem with it: cannot tap in text mode. Well, let me expose it...

* The golden days: when my laptop (HPOmnibook XE3-GF) was running Debian stable, kernel 2.4.18, I succesfully used gpm (device /dev/psaux, type synps2, repeater on) and I could tap; I also created an /etc/gpm-syn.conf file (not documented in gpm package, but see http://www.bisente.com/programas/parches/gpm-synaptics/ficheros/gpm-syn.conf); under X, I simply used /dev/gpmdata (the gpm repeater device). All worked perfectly.

* Today: Debian testing, kernel 2.6.8 (CONFIG_INPUT_EVDEV=Y, CONFIG_INPUT_MOUSE=Y, CONFIG_MOUSE_PS2=Y, CONFIG_MOUSE_PS2_SYNAPTICS=Y), mouse recognised at boot time as Synaptics PS/2 on, but.....

    - UNDER XWINDOW, no problem with xfree86-driver-synaptics.deb installed & /etc/XF86Config-4 edited as documented; a very good driver, many thanks to all developers and mantainers! :-O

    - IN TEXT MODE: gpm works only with device=/dev/[psaux|input/mice|input/event0], type=imps2|autops2, losing tap functionality, third button, ecc. If I try with type=syn|synps2 and enable debugging (-D) and error printing (-e), I see a lot of "error read()ing: couldn't find file" messages.

Anyone can help?

    Piero Furiesi

(*)I read threads started by: ".: Alex Budianto :."; "jyb"; "The Durston-Smiths"; and "Filipe Santa-Clara".

I installed Debian Unstable recently on a new Dell Inspiron 5160. Most of the stuff is working. Synaptics needed some work, but the portion of XF86Config from here worked (with touches, simulated right click and middle click, click and drag, etc.; meaning no need to click the button near the touchpad):

Let me know if this doesn't help, I can give more details what I did.


Reply to: