[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Install CD doesn't recognize my hard drive

First and foremost, thank you to all of you who responded to my original post. Whether I end up trying all of the suggestions or not, I learned from each one, and appreciate the effort to help me out.

A number of the responses revolved around "install another version" (fill-in-the-blanks) and then "upgrade" to "unstable", etc.

Considering that this sounded like the shortest route to success, and considering that I have the Xandros 2.0 Deluxe CD's which I know install correctly on the machine, I decided to go that route.

So, I successfully reinstalled (for the third time) XD. From there, I put in the debian unstable cd, and ran "apt-cdrom add" to add it my sources. I deleted all of the default sources. Then I did an "apt-get dist-upgrade".

This all worked, but it wasn't really what I wanted, because I ended up with newer packages, but still running the default Xandros 2.4.22 kernel, with their desktop.

OK, so I changed my apt sources to point to network mirrors, and did an "apt-get install kernel-image-2.6.4-1-686" (plus lots of other "recommended and suggested" packages). That worked as well. The "setup" phase first warned me, then offered to perform the update of /etc/lilo.conf. I told it to perform the update.

When I checked lilo.conf afterwards, it wasn't updated. I added another section by hand, pointing at the new initrd image (which wasn't gzippped, like the Xandros one).

When I rebooted, I didn't see the new kernel in the list of boot choices, and now booting off of the original kernel (which was not changed), just hangs. The kernel gets loaded, but the next message says "initializing kernel...", and it sits there forever.

Obviously, I can start from scratch, but before I bang my head against the same wall again, does this sound familiar to anyone? I also have a rescue boot floppy from the Xandros install, so I should be able to get back into the system as currently configured if there is something else I can try to get this going again (though I haven't actually tried that yet).

Thanks again for all of the responses!

Reply to: