[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: trackpad/button vs. external mouse

Hash: SHA1

On Friday 13 June 2003 18:03, Nori Heikkinen wrote:

> I tried following the instructions here, but nothing worked.  then a
> friend and i traded mice, and his ps/2 mouse works fine, when my usb
> one wasn't!  and i do have USB support in my kernel, i'm sure, because
> my (USB) keyboard is working.  weird ... but solved, i guess :)
> thanks,
> </nori>

This is what I did:

1st) Assured that the "HID input layer support" ("USB support" kernel menu) 
was enabled in the kernel configuration (AFAIK, you can only build in this 
option, not compile it as a module). If not, you should recompile your kernel 
with this option enabled!

2nd) Did uncomment (or even manage to use this) the following section in
(as you can see, I've got a Logitech USB Optical Mouse)

Section "InputDevice"
        Identifier      "Logitech Mouse Opt"
        Driver          "mouse"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "ChordMiddle"           "true"
        Option          "ZAxisMapping"          "4 5"

The "SendCoreEvents" allows the driver to work together with the other drivers
for pointing systems you have (such the touchpad and the "built-in botton").
At the end of the same file, in the "ServerLayout" section, you should even 
add the marked line:

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Synaptics Touchpad"
        InputDevice     "Logitech Mouse Opt"   <-----

Feel free to change the names of the device, but remember to be coherent first 
and then! The name must be the same: if not, it won't work!

3rd) Let the kernel load at boot time the following modules:


plus all the other modules you already got in the /etc/modules file.

This should help you solving the problem: it helped me!
Let me (us) know if it works.
Have fun.


- --
Matteo Vescovi
Email: mbishops(at)tiscali(dot)it
GPG Key: http://web.tiscali.it/revese/dhc_key.asc
Fingerprint: 18CE 32E6 399B 8212 549E  1E1F C299 A22E 184C 01CA
Version: GnuPG v1.2.1 (GNU/Linux)


Reply to: