[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New XE3, many questions

On Wed, Feb 20, 2002 at 01:09:15PM +0200, Pavel Mihaylov <bin@bash.info> wrote:
> alsa init script first loads modules then does "alsactl restore" to get
> your mixer settings back to the stage saved by "alsactl store" (usually
> invoked by /etc/init.d/alsa stop). On my XE3 (ESS Maestro3 card) I had
Yes I know, and this works here too. The volume levels are restored, and the
channels are unmuted by alsactl.

BUT when I start to play a song I can't hear it (or sometimes only very
quitely). I need to go to a mixer (alsamixer) and either change a littlebit
the volume of Master (sometimes even PCM needed) or mute & unmute them.
After this the volume will be fine.

> to put "sleep 2" between the module loading and volume restoring, else
> it wouldn't restore properly.
This didn't help.

I think this is a hardware bug. I don't remember how it worked with the
2.4.17 kernel's oss drivers (I just wanted to try them out, made alsa stop,
and modprobe maestro3, but I got kernel crash :(((( so this is the second
time I type in this letter...) Any idea?

For now putting 
amixer sset 'Master' mute > /dev/null
amixer sset 'Master' unmute > /dev/null
after alsactl restore helps, but sometimes I need to do this for other
channels too.

> irdaping is part of the irda-tools package. You also need the
> irda-common package -- the irattach program to "attach" your IR device.
> Of course kernel support should be also present ;) I've had success with
> Siemens S35.
Well I don't know which of the different IR types should I set in the BIOS.
Normal/IrDA/FIR/something else which I don't remember now.
THe only thing I could do was that I could see the IR blinking with a night
camera when I made irdaping. But irdadump didn't say anything when I sent
or printed a namecard from Nokia 6110, neither saw the phone anything
when it was put to receive other IR calls.

> > 7. The LCD panel's clock isn't running. It means, that when I boot
> > it syncronizes to CMOS clock (well it's on GMT, but anyway), but it
> > doesn't refresh later. So let's say I turn it on at 2:00, and it's on
> > for 3 hours, but the LCD's clock is still on 2:00. (The ":" is blinking
> > though) Is it only a problem in my machine or anybody seen such things?
> no such problem here. Do you have this problem only when you run Linux
> or also with other operating systems? Just boot some DOS floppy and see
> if the problem is there too -- then it is a hardware/BIOS/whatever error
> and you can pursue HP to fix it for free (if you have the warranty of
> course :))

Well I just checked this out today. I went to the shop where I bought the
notebook and had a look to the same model. It was running XP, and the LCD
shaw the same time as on the panel of windows. But I did another try!
When I booted that machine and entered BIOS setup, the clock on the LCD just
stopped. I think this is something like "winclock" (like winmodem) it needs
a driver. The bad thing is that even when I turn the notebook off it
continues from the time of the last reboot, when BIOS somehow syncronized it
to the CMOS clock. I think I'll write to the HP hepldesk, maybe they could
fix this in a future BIOS update. (but I guess Linux driver would be
necessary anyway to work it during linux session)

> > 9. Any methods to change between LCD and external monitor output without
> > reboot? (This new XE3 has i830MG. As I saw the older machines had Savage,
> > and there was a utility to change between outputs)
> Indeed mine has Savage, switching between LCD/CRT is done by Fn+F5
Well it's printed on the keyboard, but does nothing. Maybe it blinks the LCD
when it's on LCD, but now I'm using external monitor, and does nothing)

> > 10. Any success with KDE? I found on the net that it's a bug in X 4.1's VESA
> > driver, and I have to upgrade to 4.2. Is it worth? Will it work?
> If you get X running you can get KDE too. It's always best to upgrade to
Well no :( I'm using icewm-expermental (gnome) at the moment, because KDE
hangs when it starts. I found this bug on the internet too, so I'll try it
with 4.2...

> > 11. Any success wit the inet and CD buttons? I saw in the archive that
> > someone sent some "code" for enabling the scancodes, but it's not real code.
> > Anybody's got a utility for enabling them?
> I'm very much interested too!!

Well if there's anyone who had ever coded kernel-source and would like to
help us, let me know. I found a posting on some of the lists I checked (I
think on Omnibook list) and someone sent a small peace of code that HP says
would turn on the keyboard to send scancodes for these keys too. I had a
look and the 1st I recognized was that a "}" was missing somewehere, so
that's about the usability of the code :) There are some #defined values in
it, but the #defines are not there. Plus I think it's from some kind of
windows-compatible C language dialect :) But it doesn't seem to be too
complicated. I had a look at the kernel source's kbd driver, and if I knew
what was that code about (some in and out stuff to port 64) maybe I would
try to hack the kernel, but I have no clue. Tell me if you want the code!

> > 12. Any success with TouchPad other than simple 2 button (3rd emulated)
> > PS/2? synps2 doesn't work, IMPS/2 doesn't work. The two middle buttons
> > don't send any codes.
> The XE3 has a Synaptics touch pad. 1 or 2 weeks ago there was a thread
> with a working solution to get one of the scroll buttons as a third
> mouse button under X. Search the list for "Synaptics touchpad".

I found it, and well it works better than the things I tried so far, but
still has some problems. Under X when I move my finger on the touchpad
and release it, the cursor goes on 'till it reaches the edge of the screen.
And the real buttons of the pad doesn't click sometimes, though tapping seem
to be ok. At least the middle button is producing klicks :)
So I might go back to 2 button MS type, but I'll try it out in the next


Reply to: