[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: about Xe3

On Wed, Feb 20, 2002 at 12:54:54PM +0100, bpgm <bpgm@pop3.libero.it> wrote:
> I have this laptop too (although now is at assistance) and I want to know
> if somebody know how to configure the chipset i830m in the XF86config.
I use 4.1 at the moment with VESA FB, but also plan to try it with 4.2
My XF86config-4 looks like this:

Section "Device"
        Identifier      "Intel i830MG"
        Driver          "vesa"
        VideoRam        8192
        Option          "UseFBDev"              "true"

Section "Monitor"
        Identifier      "Generic Laptop Display Panel 1024x768"
        HorizSync       30-60
        VertRefresh     50-75
        Option          "DPMS"

Section "Monitor"
        Identifier      "MAG XJ796"
        HorizSync       30-96
        VertRefresh     50-160
        Option          "DPMS"

Section "InputDevice"
        Identifier      "TouchPad"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/gpmdata"
#       Option          "Protocol"              "Microsoft"
        Option          "Protocol"              "MouseSystems"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Monitor Screen"
        Screen          "LCD Screen"
        InputDevice     "XE3 Keyboard"
        InputDevice     "Generic Keyboard"
        InputDevice     "TouchPad"
        InputDevice     "Generic Mouse"

It worked also with the default settings when I choose vesa in the

Unfortunatelly i830MG only supports 60Hz at 1024x768 and 1280x1024, so the
external monitor is quite uncomfortable to look at.

> It's possible with the new 4.2? Or I have to start in Framebuffer?
> If "yes", I have to install the new Xf86, I tried this with the 4.1 version
> and this required GLibc 2.2, where can I found this? (Sorry, I'm very awkward)
What disro are you using? It should be very old if it doesn't have it by

> Another thing: with the bios GF.M1.01 the key 's' doesn't function at the
> start, with the new bios 1.04 it works correctly?

Yes it works, you should upgrade your BIOS IMHO.


Reply to: