[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apm support changes 2.2.19 > 2.4.16

Michael Hothorn <mhothorn@ix.urz.uni-heidelberg.de> writes:

> Hi all, 
> I switched from potato to woody on my thinkpad i1200. APM support worked
> for t 2.2.19 very well. Installing 2.4.16 with the same options
> 	<*>   Advanced Power Management BIOS support               
>         [ ]     Ignore USER SUSPEND                   
>         [*]     Enable PM at boot time                         
>   	[ ]     Make CPU Idle calls when idle           
>   	[ ]     Enable console blanking using APM      
>         [*]     RTC stores time in GMT      
>         [*]     Allow interrupts during APM BIOS calls  
>         [*]     Use real mode APM BIOS call to power off      
> After booting the new kernel, apm says: Kernel build with no APM
> support. /proc/apm does not exist!
> append= apm=on in /etc/lilo.conf does not change anything 
> any ideas?

If it makes you feel any better, something similar happened to me
somewhere around 2.4.7.  The previous 2.4.x had worked fine, and the
next release worked.  But, when I booted the bad kernel, apm would
appear to initialize fine in dmesg, but there wasn't a /proc/apm.

Brian Nelson <nelson@bignachos.com>

Reply to: