[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PCMCIA -- Unstable -- Kernel 2.4.12


   Thank you for your remarks.

   I have read so many online documents about kernels and upgrades
and patches etc. that my eyes and head hurt!  I have killed entire
forests with all that I have printed out to read again and mark up and

   At this point I could use some very simple instructions.  I am not
shy about just trying something but prefer not to waste several more
days doing so blindly and having to start all over again.

Current Status:

   Progeny-Debian-Linux is on my HP OmniBook 4100 laptop.

   Progeny uses Grub rather than Lilo, so I am at a disadvantage
when references are made in most documents to adjusting Lilo --
what do I do about Grub?

   I ran the upgrade from Progeny to Unstable yesterday and the
laptop has sat without being rebooted since then as I try to find
someone who can tell me if I reboot it I will still have pcmcia ...
otherwise I will probably have to wipe everything out for the 5th
time and restart with Progeny from the CD.

   I have downloaded kernel 2.4.12 and it resides in /usr/src/

   From whence do I also download pcmcia-cs to match kernel
2.4.12 and Unstable?  (I looked around and the only site http
site I found would not respond.)

   What are the steps I should follow, please?  Reboot Unstable,
install kernel 2.4.12 (specific recommended commands?) ... reboot?
... then install pcmcia-cs (specific recommended commands?) ?

Yes, I am exhausted ... also because I am doing this at the same time
my in-laws are visiting for a week!  :-)

Thanks!  Doc

> you can do pcmcia support under 2.4.x in two ways:
> installing the pcmcia packages (more stable, but maybe less feature-rich,
and somewhat more complex to setup).
> Compiling pcmcia support into the new 2.4.x kernel, however, note that
you'll still need the pcmcia-cs package installed for full pcmcia support.
> it's really up to you. Check the documentation for the 2.4 kernel series,
and see what it says, and what you're comfortable doing. I personally chose
to use the 2.4 kernel modules, partly 'cause I was having trouble getting
pcmcia packages to compile properly with the 2.4.9 kernel.
> You don't, however, *have* to upgrade your kernel. And even if you do,
 it's probably wise to have a pretty good idea of what's oging on and how to
use lilo before you do..
> glen
> On Tue, Oct 23, 2001 at 10:31:12PM -0400, eDoc wrote:
> > Did you have to download and install a separate pcmcia package as well?
> >
> > What did you download and from where, please?
> >
> > I am currently seeing Cardbus Services handle my 3Com 3c589 nic (under
> > Progeny and kernel 2.2.18).  I am not clear as to what handles my nic
> > Unstable and kernel 2.4.12 (which I just downloaded but have not
> >
> > Where do I go from here, please?
> >
> > My plan is to reboot with Unstable, then install 2.4.12 ... but I need
> > know
> > from where and what precisely I need to download to be certain I can get
> > pcmcia back up should Unstable and/or 2.4.12 kill it.
> >
> > Thanks!  Doc
> >
> >
> >
> > > You can use any version you want (within limits). I moved to woody and
> > > now run 2.4.10.
> > > T.
> > >
> > > >I am guessing that since I upgraded to Unstable I should also upgrade
> > > >a newer kernel and matching pcmcia?
> > > >Yes?
> > > >Thanks!  Doc
> > > >
> > > >>Make sure you match your pcmcia-modules to your kernel. Look at the
> > > >>packages and be sure your the version for pcmcia-modules is exactly
> > > >>same as your kernel version (e.g., 2.4.10 or 2.4.10-smp,...)
> > > >>Tim
> >
> >
> >
> > --
> > To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
> > with a subject of "unsubscribe". Trouble? Contact
> >
> --
> Glen S Mehn
> Lead Systems Administrator SquareTrade, Inc
> glen@squaretrade.com Building Trust in Transactions (sm)

Reply to: