[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XF4.02 SiliconMotion driver hanging my ASUS 7300

On Sat, Feb 24, 2001 at 08:38:56PM -0800, Heather wrote:
> > On Tue, Feb 13, 2001 at 12:20:05PM +0800, Jonathan Chang wrote:
> > > Hi, there,
> > > 
> > > 	My laptop is ASUS 7300 equipped with SMI 910 lynx
> > > chip. Recently I upgraded XF4.0 to XF4.0.2, but the system hung after
> > > "starx". Anyone has similar experiences??
I just installed the 4.0.2-7 debs.  When I run 'startx' I get

X: cannot stat /etc/X11/X (No such file or directory), aborting.

It "hangs" for a few seconds then quits with:

giving up.
xinit:  No such file or directory (errno 2):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.

However, 'XFree86' starts the server properly.  xdm won't start correctly
either, and debconf fails to write any XF86Config files.  It asks me all
the questions, says it's going to write the file, and finishes without
warning.  But no XF86Config.  However 'XFree86 -configure' gave me a file
in about 2 seconds.  Although it identified the device properly, (Trident
CyberBlade i7/DSTN) the config didn't work.  For this machine, one must use
the fbdev driver, not the trident driver, which is what I chose with debconf.
There was also a missing dependency for xfonts-base.  I never installed it
and dpkg never complained.  So it seems to me there are still some issues to
be resolved in the unstable debs, which is why they are called unstable :)

> Make sure your networking is in good shape.  My system loves to get a headache
> if I forget  to cardctl eject when I'm not on a network :(
> Also since startx is a shell script (unless it's been changed) you should
> be able to add -x on its #! line and get it to tell you what's going on inside
> its tiny little brain.
> You could try runningt he X server "raw" just to see if that loads up.
> > Yes, I have the same laptop and the same problem with all 4.0 versions I 
> > tried. I submitted a bug report to XFree86 about 2 or 3 months ago, but 
> > didn't get an answer yet.
> Hmmm...

I think, but I'm not sure, that the problem is with the debs (or maybe the
debian system [asbestos on]), or just not 100% compatible out of the box.
In that case, you wouldn't get a response.  


Reply to: