[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IBM Thinkpad 770 - Mouse "goes crazy" in X (fixed!) but now Keyboard is acting weird!



Thanks for the suggestions guys, my mouse now works properly after I got rid of gpm. However, when I enter Gnome now and start Gnome Terminal, some of my keys on the Thinkpad are not mapped correctly. For example, when I press the "/" key, I get a "-" (which was almost disastrous as I was trying to search something in dselect and ended up almost uninstalling some random apps) and when I press "&" I get "/" and other weirdness. It's probably a keyboard setting file or something right? Can you point me to the right direction? It works fine in the regular console (non-X) of course...

Still learning...


At 01:02 PM 11/8/2000 +0900, sen_ml@eccosys.com wrote:
From: Iohan <linux@ochupu.com>
Subject: IBM Thinkpad 770 - Mouse "goes crazy" in X
Date: Tue, 07 Nov 2000 22:17:24 -0500
Message-ID: <5.0.0.25.2.20001107221032.02c7b2c0@mail.ochupu.com>

> My X 3.3.6 runs fine, but the mouse just jumps around uncontrollably. I've > tried just the built-in trackpoint, and I've tried plugging in a regular MS
> Intellimouse in the PS/2 port.  Same problem.
>
> I've tried modifying the XF86Config with different protocols - "PS/2",
> "Microsoft", and "Intellimouse".
> I've tried modifying the device in XF86Config - "/dev/psaux", "/dev/mouse",
> "/dev/gpmdata"
> I've tried with and without "Emulate3Buttons"
>
> The mouse works fine in text mode. But when I start X, it is uncontrollable.

if you are running gpm, have you tried disabling it before starting X?


--
To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: