[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PCMCIA trouble in latest potato


hello gary,

i just re-upgraded my slink lapbox (sony
picturebook--vaio pcg-c1xs) to potato around 0300 this
morning.  (btw, there was no prob having done it on my
deskbox a few weeks ago.)

anyway, this is what i did/observed:

1.  when it paused to ask if i wanted to shutdown the
pcmcia services, i "said," "no."

2.  then it just resumed with the rest of the potato

3.  after the install, i was successful with a "pon" to
the isp.

4.  i disconnected and then rebooted--the "smoke test."

5.  during the boot (on a 2.0.36 kernel, no less) i was
happy to hear the 2 "high" beeps for the card modem

6.  but when i tried to "pon," it just sat there.

7.  i looked at the ppp log file and saw that there was
some problem with "chatscripts."

8.  i ran "pppconfig," again; even though i hadn't
changed anything in that file from the time "pon"
worked to the time it took to disconnect from the isp
and then reboot for the "smoke test."

9.  in the "pppconfig," i let it probe for the
available pcmcia (modem) device/location.  (under
slink, it was /dev/ttyS0.)  surprisingly, under potato,
it found /dev/ttyS1 for my card modem.  (it looked and
felt strange, but at that time of day, i wasn't in the
mood to be picky.)

10.  i finished the "pppconig" and rebooted.  (old,
nasty microcrap habits die hard.)

11.  the same 2, high beeps greeted me for the pcmcia
card services during the reboot.

12.  i logged in and issued, "pon" for my isp.

13.  it dialed up perfectely as it had done under

14.  my unsophistated assessment is that potato moved
the device from ttyS0 to ttyS1; and that the system
needed a "potato" pppconfig, rather than using the one
from slink.

given the above, does your boot result in the 2, high
beeps for the pcmcia card services?  if yes, it may be
beneficial just to run "pppconfig" and let the software
probe for the pcmcia device/location.  if no, do you
get a high beep and then an octive-lower beep?  that
may indicate a prob with the pcmcia card services
file/install/whatever.  (sorry, i can't be of much help
with this type of situation.  perhaps some other folks
can chime in.)


bentley taylor.


Gary Hennigan wrote:
> Sorry if this is a repeat for some of you, but a more informed person
> than I pointed out the laptop-specific Debian group so I'm reposting
> this from debian-user.
> ----------------Slightly modified forward from debian-user--------------
> Anyone else having PCMCIA trouble with the latest version in potato? I
> just tried installing
> kernel-image-2.2.15_2.2.15-1.deb
> pcmcia-modules-2.2.15_3.1.8-13k1.deb
> and the PCMCIA modules are giving me a lot of unresolved symbols
> whenever an attempt is made to install them. I tried compiling from
> the source.deb files as well, using make-kpkg, with the same result,
> including a 2.2.14 kernel source file.
> I got the basic installation up on the laptop a couple of days ago and
> it worked fine. Now I'm stuck without a network connection because of
> the PCMCIA stuff. I'm not a newbie at this either, I've kept my own
> kernel and pcmcia on a Thinkpad through at least a half dozen
> upgrades. Anyone else see this? Anything changed in the way the kernel
> needs to be configured for PCMCIA to work? Any suggestions at all?
> Thanks,
> Gary
> --
> To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: