[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Knoppix/Quantian on Proliant DL360 G3 with 5i Smart Array, no hard disks visible

needless to say, if this is knoppix, you should probably
be doing something like
   mkdir /mnt/c0d0p3
   mount /dev/ccis/c0d0p3 /mnt/c0d0p3
rather than mounting directly on /mnt -- which would
break a lot of things for Knoppix

If you'd like to put the mountpoints into /etc/fstab:

for part in ` awk '/cciss/{print $4}' /proc/partitions `; do
   mnt=/mnt/${part#cciss/}  ;
   mkdir $mnt
echo "/dev/$part $mnt ntfs noauto,users,exec,umask=000,uid=knoppix,gid=knoppix 0 0" >> /etc/fstab

Shane Geiger wrote:

If you have kernel module support for your hardware, the following
instructions will help you.   (Meaning, this shhould work for,
according to what you said.)

1)  Find out which partitions you have:

sgeiger2@lnksr:~$ cat /proc/partitions
major minor  #blocks  name

104     0  142261440 cciss/c0d0
104     1     975104 cciss/c0d0p1
104     2  117185760 cciss/c0d0p2
104     3   20506080 cciss/c0d0p3
104     4    3594480 cciss/c0d0p4

2)  Mount the partition:

sudo mount -t ext3 /dev/cciss/c0d0p3 /mnt

In your case: use "ntfs" instead of "ext3," like this:
sudo mount -t ntfs /dev/cciss/c0d0p3 /mnt

3) Verify that it was mounted:

sgeiger2@lnksr:~$ mount
/dev/cciss/c0d0p2 on / type unknown (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/cciss/c0d0p3 on /mnt type ext3 (rw)

FYI: To get a little information that would be helpful in knowing which
partition to mount, do this:

sgeiger2@lnksr:~$ sudo fdisk /dev/cciss/c0d0

The number of cylinders for this disk is set to 34868.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
  (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/cciss/c0d0: 145.6 GB, 145675714560 bytes
255 heads, 32 sectors/track, 34868 cylinders
Units = cylinders of 8160 * 512 = 4177920 bytes

          Device Boot      Start         End      Blocks   Id  System
/dev/cciss/c0d0p1               1         239      975104   82  Linux swap
/dev/cciss/c0d0p2   *         240       28961   117185760   83  Linux
/dev/cciss/c0d0p3           28962       33987    20506080   83  Linux
/dev/cciss/c0d0p4           33988       34868     3594480   83  Linux

Command (m for help):

Then you should be able to do "cd /mnt" and "ls" and see some files.

Martin Schenker wrote:

Hi all!

Is there an easy solution for auto-mounting a SCSI array while starting Knoppix/Quantian on a HP Proliant DL360 G3 (with 5i Smart Array) server? The hard drive(s) don't show up after booting. I'm not that familiar with the LINUX env., so any pointers in the right direction are appreciated. I've tried to get some information from the various Knoppix sites on the web, but only could find very little (see below)

I've tried the releases and, here are the results:

I tried the following approach, running the linux24 kernel (linux26 resulted in a kernel panic):

-Open a shell window. -Type 'su' (no quotes) to become root. -Type 'insmod cciss' -Type 'cd /dev' -Type 'MAKEDEV cciss' (this is case-sensitive).
OK, so far, so good. How do I acces the drive from there? (Still no icon on the desk, don't laugh...)

I can see both drives with qtparted, both have been NTFS formatted (the machine was running Win2003 server before). Running Quantian on my Laptop brought all the NTFS drives up without any problems, so I assume the 5i Smart Array is the culprit... Right now I don't want to reformat the drives, I'm still testing...

With the new release, the "insmod cciss" command seems not to work anymore. It complains insmod can't find the file "ccicc". I can run the kernel 26 without a major hickup, but kde has a problem and generates an error. After closing and restarting a new session it seem to behave. But still no drives visible.
Thanks for any help! Pointers and/or advice would be appreciated...

Best, Martin

Dr. Martin Schenker

Stephen Samuel +1(604)450-0066             samnospam@bcgreen.com
  Powerful committed communication. Transformation touching
    the jewel within each person and bringing it to light.

Reply to: