[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#656341: KMS not enabled with ATI Radeon HD 6310 (but it works with Ubuntu 11.10)

On Thu, 19 Jan 2012 13:28:54 -0600
Jonathan Nieder <jrnieder@gmail.com> wrote:

> Ah, ok.  Please attach full "dmesg" output from booting.

Ok, I'm attaching even two: one is dmesg_debian_3.1_no_drm, from the
official Debian package, where it does not even seem to try loading the

The other is "dmesg_loading_fails_selfcompiled" where it tries to load
the firmware, but says it can't find it. The kernel was built with:


CONFIG_EXTRA_FIRMWARE="radeon/PALM_pfp.bin radeon/PALM_me.bin
radeon/SUMO_me.bin radeon/SUMO_pfp.bin radeon/SUMO_rlc.bin
radeon/R600_pfp.bin radeon/R600_rlc.bin"

> I guess I'd suggest "apt-get reinstall firmware-linux-nonfree",
> although since ...

I tried that (apt-get install --reinstall), 

When I did that it also updated the initrd:

Preparing to replace firmware-linux-nonfree 0.34
(using .../firmware-linux-nonfree_0.35_all.deb) ... Unpacking
replacement firmware-linux-nonfree ... Setting up
firmware-linux-nonfree (0.35) ... update-initramfs: deferring update
(trigger activated) Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-rc7-amd64
FATAL: Module xhci not found.
FATAL: Module ext4dev not found.
FATAL: Module af_packet not found.
FATAL: Module atkbd not found.
FATAL: Module i8042 not found.
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for
module r8169 W: Possible missing
firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169 FATAL:
Module zfcp not found. FATAL: Module dasd_diag_mod not found.
FATAL: Module dasd_eckd_mod not found.
FATAL: Module dasd_fba_mod not found.
FATAL: Module unix not found.
WARNING: could not
open /tmp/mkinitramfs_hm3ETZ/lib/modules/3.2.0-rc7-amd64/modules.builtin:
No such file or directory

Just to make sure I also updated the initrd of kernel 3.1.0-1-amd64 and
rebooted, but still no change.

> What package does "dpkg-query -S /lib/firmware/3.2.0-rc7" indicate is
> responsible for those?

linux-image-3.2.0-rc7, that's a self-compiled kernel.

> Not related, but you can fix this with
> 	echo 'APT::Default-Release "sid";'
> >/etc/apt/apt.conf.d/80vp-prefers-sid

I had
"Pin: release a=sid
Pin-Priority: 650"
in /etc/apt/preferences, so I was surprised reportbug reported
"APT policy: (600, 'experimental'), (500, 'unstable')" - maybe "sid" is
different from "unstable" in this case? But that's not the point here.
Thanks anyway!


Attachment: dmesg_debian_3.1_no_drm
Description: Binary data

Attachment: dmesg_loading_fails_selfcompiled
Description: Binary data

Reply to: