[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED, kind of] Re: Buster: Has anyone been able to run an app as root in KDE?

Oct 12, 2018, 12:23 PM by luigi.toscano@tiscali.it:

> Kate can't run directly as root, but there is a way to edit files a root:
> https://phabricator.kde.org/D4634 <https://phabricator.kde.org/D4634>
> https://blog.martin-graesslin.com/blog/2017/02/editing-files-as-root <https://blog.martin-graesslin.com/blog/2017/02/editing-files-as-root/>

Your post game me some ideas, and I tried to run Kcalc as root and it worked[1] just fine. So it looks like KDE is simply preventing some apps to be run as root yet allowing others. What can I say... I wish the error message would've been phrased better, at least giving the user some ideas as to what is happening instead of generic "KDEInit could not launch...".


[1] - After running "kwriteconfig5 --file kdesurc --group super-user-command --key super-user-command su" as it was suggested by yaros

Reply to: