[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Buster: Has anyone been able to run an app as root in KDE?

Dnia wtorek, 2 października 2018 05:40:37 CEST local10 pisze:

> Hi,


> Has anyone been able to run an app, any app, as root in KDE? If yes, how do you do it? I tried the following approach with several apps  but it did not work for me:


> 1. Select an application launcher (tried it with Kwrite, Konqueror) > RMB click > Edit launcher (or Edit Application) > Application > Advanced Options > User > [X] check Run as a different user > User name > root


> 2. Launch the app, it launches, asks for the (root) password, enter the password, click OK, the app just sits there for several minutes. Trying to close the Enter password window results in "Application kdesu is not responding" and offers to terminate application kdesu. I can terminate it but that's about it.


> Thanks





Try this (command as user, not root):


kwriteconfig5 --file kdesurc --group super-user-command --key super-user-command su


That makes su default super user command instead sudo. (source: https://wiki.archlinux.org/index.php/Sudo#kdesu)


Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: