[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE 3.2.2 for Woody... Careful upgrading..

Hello Michael!

On Tue, Apr 20, 2004 at 08:00:06AM -0700, Michael Peddemors wrote:
> On April 20, 2004 01:14 am, you wrote:
> > First of all, apparently you're using "apt-get install" for upgrading
> > packages.  This is a bad idea.  Use dselect, aptitude, synaptic, these
> > do a much better job at automatically handling dependencies.
> The packages themselves are meant to handle dependencies, that is the beauty 
> of Debian isn't it?

Well, actually the Debian package format allows to state dependencies
(ranging from hard Depends: via medium Recommends: to soft Suggests:)
rather than letting the packages handle those themselves.

A higher level tool like dselect, aptitude, synaptic, and apt-get as
well, can parse these statements and conduct the best way of
proceeding from these, and if user action needs to be taken present
the user a reasonable set of choices. Some higher level tools are
»smarter« in doing so than others, though, especially when upgrading
a large suite of packages including adding and removing supplementary

So in conclusion I concur with Dominique.

Just some nitpicking,

Attachment: signature.asc
Description: Digital signature

Reply to: