[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Report: KDE 3.1.x/Woody Screensaver Situation

Re: my previous reports to this list (Jan.2003 & Feb.2004) about how on 
my Woody system with KDE 3.1.x,  (a) the OpenGL screensavers were very 
slow (unaccelerated), and (b) most of the ~160 screensavers listed in 
Kcontrol don't work at all :

I've been experimenting, and have made two improvements in the situation 

1)  I now have beautiful glorious fully accelerated GL screensavers (the 
KDE ones anyway); I fixed the problem by installing a package I hadn't 
previously realised I needed : libglide3, "Graphics library for 3Dfx 
Voodoo based cards";  I suppose users of other brand graphics cards 
don't need any such "helper" library (or do they ?).

2)  I managed to remove the entries for approx 145 screensavers which 
don't work from the list offered by the screensaver applet of Kcontrol 
(leaving 29 working native KDE screensavers).  The screensavers listed 
by Kcontrol are those for which a ".desktop" file exists in 
/usr/share/applnk/System/ScreenSavers, so I just moved the "broken" 
ones out of the way.

I tried to find out why exactly the broken screensavers are broken, and 
noted that the first few lines of a working screensaver .desktop file 
are like this :

  /usr/share/applnk/System/ScreenSavers$ more KPyro.desktop
  [Desktop Entry]

and the "Exec" line names an executable file to be run :

  /usr/share/applnk/System/ScreenSavers$ which kpyro.kss

but for a "broken" screensaver (e.g. "Zoom"), the named executable :

  /usr/share/applnk/System/ScreenSavers$ more duff/zoom.desktop
  [Desktop Entry]

doesn't exist in any directory on the path on my system :

  /usr/share/applnk/System/ScreenSavers$ which zoom

I did a search of the system, and discovered that the zoom screensaver 
module *is* on my system, in a place which isn't on the path, so it 
doesn't work :


Thus enlightened, I tried editing the zoom.desktop file to add the full 
path for the screensaver module to each "Exec" line (there are 4 such 
lines).  This fixed the basic brokenness of the Zoom saver, such that 
it will now actually work if selected in Kcontrol - *but* didn't fix 
the Kcontrol screensaver preview pane (which stays dark), or the "Test" 
button (which does nothing at all)... and the "Setup" button just says 
"No configuration available for Zoom".   This situation seems to be the 
same for each of the xscreensaver modules - all the .desktop files are 
broken in the same way, and all can be "fixed" by adding the full path 
to the executable module.

So where does "zoom.desktop" come from ?

glimmer:~# dpkg -S zoom.desktop
kscreensaver: /usr/share/applnk/System/ScreenSavers/zoom.desktop

glimmer:~# apt-cache policy kscreensaver
  Installed: 4:3.1.4-0woody1
  Candidate: 4:3.1.4-0woody1
  Version Table:
 *** 4:3.1.4-0woody1 0
        500 http://download.kde.org stable/main Packages
        100 /var/lib/dpkg/status

Okay .... it's a fault in the kscreensaver package at download.kde.org.
Should I bug this ?   Ralf ?

End of report.

(1) Should I fix all 145 broken xscreensaver .desktop files - or just 
move the xscreensaver modules to a directory on the path ?  
That would allow them to be selected directly from Kcontrol.

(2) After that, is there any further need for the "XScreenSaver.desktop" 
file ?  Its only purpose seems to be to allow Kcontrol to run 
"xscreensaver -setup" to give the horrible Motif-y xscreensaver 
configuration dialog ... which I suppose *does* provide the ability to 
have a subset of the modules selected, but that in turn only works if 
we have the xscreensaver daemon running ... which is equally horrible 
(ok - I mean "un-KDE-ish").

(3) How come some people find all 160 screensavers work from Kcontrol 
without the problem I found ?   (I'm thinking perhaps there are 
different .desktop files in other packagers' KDE debs ...)

Nick Boyce
Bristol, UK

Reply to: