[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

pgp/mime support in kmail

hello folks

i'm having quite a few problems, setting up pgp/mime support in kmail -
it's possible that this problem isn't debian specific at all - i just thought
i'll ask here first.

another question first (ok, this may be offtopic - sorry for that. which
list would you consider asking this?):
i'm using unstable and it's not easy, installing all components 
needed - debian mirrors don't provide pineentry or newpg. 
i had to fetch them from an unofficial source 
why does unstable lack the support for openpgp/s-mime?

anyway - my problem is:
i followed the pgp/mime-guide at http://kmail.kde.org/kmail-pgpmime-howto.html
i successfully set up pineentry (both qt and gtk versions) and also tested
it on the commandline - where it works without problems (the qt or gtk-dialog
appears and my passphrase is kept in memory).

in kmail, i configured the openpgp-plugin under security/cryptoplugins and
also activated it.

first question:  do i have to keep the inline openpgp-interface (in the tab
openPGP) activated or shall i deactivate it?

i deactivated it - but it doesn't seem to change anything. my old messages
which were decrypted using inline-openpgp still get decrypted using the

second question: do both methods (plugin and inline) work properly together
or do i have to get rid of one (supposedly the inline-one) ?

ok, i then went over to the few pgp/mime-mails i had received and hoped that
i would finally be able to decrypt them. but i still get the same error on 
every message:

Cannot decrypt message.
Error: No passphrase.
Content could *not* be decrypted.
reason:No passphrase.
End of encrypted message

i also get this error when i encrypt something on the command-line and my
passphrase is in memory.

third question: what have i missed or what have i done wrong?

help would be very appreciated - thanks a lot in advance!

Pascal Mainini

Reply to: