[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hosed KDE

On mån, okt 15, 2001 at 01:40:20 -0500, Shawn P. Garbett wrote:
> I recently ran "apt-get upgrade" and it completely hosed my xfree86 server. 
> After poking around for hours, it turns out that there was a hodge-podge mix 
> of 3.x and 4.0 xfree86 stuff. Not having a working server,  I finally gave up 
> and purged xfree86-common from the system ('apt-get remove xfree86-common'). 
> Then I went a step further and deleted directories that didn't get removed, 
> because of files that had changed. Then I reinstalled, xfree86, and then 
> reinstall kde. I managed to get xfree86 up and running. 
> Now the problem is, that KDM comes up with the login prompt and upon 
> attempting to log in, it just comes back to the login prompt.
> I can do a console login and start x using "startx" and then the only window 
> manager I've been able to get started is blackbox, by typing "blackbox&" in 
> the xterm prompt that startx leaves me in.
> I tried to remove kdm and it gives the following:
> System:~# dpkg -P kdm
> (Reading database ... 57474 files and directories currently installed.)
> Removing kdm ...
> Stopping K display manager:  not running /var/run/kdm.pid not found.
> dpkg: error processing kdm (--purge):
>  subprocess pre-removal script returned error exit status 20
> Errors were encountered while processing:
>  kdm
> How can I fix kdm?
I got the same problem this morning after dist-upgrading to X 4.1.0-7. I
"fixed" it by downgrading to 4.1.0-6, but haven't had time to look into the
real problem.

P.S. Is there a better way of pinning several packages to the same
release/version than giving all there own entry in /etc/apt/preferences? I
tried wildcards and writing several package names on the same "Package" line.
> -- 
> To UNSUBSCRIBE, email to debian-kde-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: