[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kpackage-2.1.1-2 crashes with sig 11

On Friday 18 May 2001  1:31 pm, mikepolniak wrote:
> On Thursday 17 May 2001 17:26, Ben Burton wrote:
> > > > > kpackage. But kpackage fails to start from icon or cmd line.
> > > > > Everything
> > >
> > > I've had this on my system too. It was gone after apt-get install
> > > rpm...
> >
> > Hi Mike.. someone else has had the same problem that was solved by
> > installing package rpm (thanks Andre!).  Could you please test this also
> > - install package rpm - and if everything works we can let Ivan know that
> > his Recommends: rpm needs to be a Depends:.
> I tested this on one of my Debian systems and removing rpm caused the crash
> of kpackage.After reinstalling rpm , kpackage started up fine. So it
> appears that with Debian, rpm is a Depends.

I don't know if this info is useful or relevant to you guys, but on my Debian 
2.2r2 / KDE 2.1.1 (without the kdelibs 2.1.2 update) / kpackage 2.1.1-0 / 
kernel 2.2.19 / package rpm *not* installed, kpackage starts fine, but always 
pauses on the way up to display a dialog box containing the message "Unable 
to open /usr/lib/rpm/rpmrc for reading : No such file or directory".

[ I suppose it should handle the missing rpm tool more gracefully than that ]

After that, kpackage initialises, and seems to process deb packages fine.  I 
haven't tried it with an rpm, so I wouldn't know. It never crashes in any 

Nick Boyce
Bristol, UK

Reply to: