[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Far funzionare virtualbox (testing) con Linux 4.12.0-1



Il 20/08/2017 09:42, Davide Prina ha scritto:
In testing (Buster) con l'arrivo di Linux 4.12.0-1 non funziona più la compilazione di virtualbox[1]... in realtà virtualbox è stato tolto da testing per problemi legati alla sicurezza[2], o meglio, se non ho capito male, a come viene gestita la sicurezza in Oracle che impedisce una corretta gestione in Debian, e per lo stesso motivo non c'è neanche in stable (Stretch).
Da quel che ho capito gli sviluppatori di Oracle che si occupano di virtualbox non possono distribuire patch per la correzzione di bachi ma devono rilasciare patch e avanzamenti di versione in un unico codice. I manutentori di debian fanno molta fatica quindi ad estrapolare solo le patch di siurezza per poterle poi applicare a versioni di virtual box precedenti; non che sia impossibile ma si sono stufati di farlo. Gli sviluppatori di Oracle d'altronde sarebbero disponibili a separare le patch dagli avanzamenti di versione ma purtroppo non possono farlo perché Oracle non glielo permette. A questo punto Virtualbox è stato rimosso da testing e quindi e consigliano di installare direttamente virtualbox dai repos di oracle.

A questo punto però mi chiedo: perché installare la versione di sid invece di quella distribuita da Oracle?

Piviul


Reply to: