[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Looking for qmail, vpopmail, webmail solution



Hi Theodor!

I am trying to set up a mail toaster on a Debian Woody system.

Here are the requirements:
- qmail
- pop3
- pop3 authentification _not_ against /etc/passwd, /etc/shadow
- virtual pop3 users
- webmail access

Just what I use down here on the farm ;-)

Good to hear!

qmail is installed and works fine. I tried to implement vpopmail and sqwebmail, but I was not able to get it to work. The sqwebmail debian package does not come with vpopmail authentification included. My attempts to build it from the source package with modified rules file all failed.

It (recompilation) works for me with just trivial changes to ./configure
line in debian/rules. What kind of problem do you have?

I installed vpopmail binary package from unstable (it is not included in woody).

<<<
dpkg --list "*vpopmail*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
un  libvpopmail-ba <none>         (no description available)
ii  libvpopmail-de 4.9.9-1        vpopmail development files
ii  libvpopmail-fr 4.9.9-1        vpopmail mysql plugin
un  libvpopmail0   <none>         (no description available)
ii  libvpopmail1   4.9.9-1        vpopmail libraries
un  vpopmail       <none>         (no description available)
ii  vpopmail-bin   4.9.9-1        vpopmail binaries
ii  vpopmail-doc   4.9.9-1        vpopmail documentation
>>>

Afterwards I tried to build sqwebmail from the debian source package. I changed the rules file:

--with-authvchkpw
--without-authdaemon

This leads to the following error during build:

<<<
echo '#include "/var/lib/vpopmail/include/config.h"' >vpopmail_config.h
gcc -DHAVE_CONFIG_H -I. -I. -I. -I/var/lib/vpopmail/include -lcrypt -Wall -I.. -I./.. -c authvchkpw.c
authvchkpw.c: In function `auth_vchkpw_changepass':
authvchkpw.c:142: warning: assignment from incompatible pointer type
authvchkpw.c:151: dereferencing pointer to incomplete type
authvchkpw.c:151: dereferencing pointer to incomplete type
make[2]: *** [authvchkpw.o] Error 1
make[2]: Leaving directory `/tmp/courier-0.37.3/authlib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/courier-0.37.3'
make: *** [build] Error 2
>>>

I found numerous occurences of this error message on Google and groups.google.com - unfortunately all without replies. :-(

What does your working rules file look like?

TIA

Dieter

--
Dieter Heiliger | dieter.heiliger@gmx.de  (private)
                  dieter.heiliger@sun.com (business)


--
To UNSUBSCRIBE, email to debian-isp-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: