[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel panic after kernel update.

First, can you tell which mainboard you have, which SATA controller you
have or is it onboard.

Next. You should note that starting some kernel version there are NO
hotplug. It got to be depricated. Udev sits it's place. Kernel 2.6.15 is
already without hotplug.

About boot loader. I didn't used elilo, so I can't tell how to deal with
it. I use grub. In grub you can edit boot parameters from withing the
boot menu.

My recommendations, install 2.6.16 or later kernel from backports.org.

And, btw, now I remember I played with 64bit kernels for Intel Pentium
and got no luck. So my suggestions - first get to work plain 32bit
kernel. After doing that successfuly you can try 64bit variant and see
the difference.

BTW, do you have Intel Itanium 64, Intel Pentium 64 or AMD * 64? 

В Пнд, 03/07/2006 в 18:44 -0700, Spundun Bhatt пишет:
> By the way, thanks Покотиленко and David for their responses, they 
> helped me go further.
> Покотиленко Костик wrote:
> > I have seem this problem on non-ia64 system.
> > 
> > First, check which root partition the kernel is said to use (root=
> > kernel option).
> > 
> > Then watch the boot process and check how your boot HDD is being
> > recognized. The most common case is when you try to boot from
> > root=/dev/hda1, but your HDD is being recognized as, say, /dev/hde1.
> Update,
> I changed the /efi/efi/debian/elilo.conf file and opted to boot using 
> the older kernel configuration.... (LinuxOld) and it booted using 
> 2.6.12-1 kernel. But I am still in a hole...
> With this kernel the udev initialization fails.... which means it doesnt 
> detect my usb mouse and keyboard anymore...
> Now is probably the right time to tell you guys this part of the story...
> All this started on friday when there was a conflict between udev and 
> hotplug in my debian installation and I asked synaptic to upgrade those 
> to resolve conflict,
> At the time of upgrading udev it said that make sure you have linux 
> 2.6,15 installed and then reboot asap because this udev only works with 
> 2.6.15 and up. So after installing udev I upgraded the package 
> kernel-image-2.6-mckinley 2.6.15-1, assuming that I upgraded the kernel, 
> I rebooted, it turned out that my linux was still booting the old 
> kernel, so my keyboard didnt work... I connected through network and 
> tried to figureout if I missed any other package, then I upgraded the 
> package linux-image-2.6.15-1-mckinley ... and this time when I rebooted 
> it seemed to try to boot with the new kernel and get a kernel panic.
> So I upgraded the following packages in that order
> udev
> kernel-image-2.6-mckinley 2.6.15-1
> and
> linux-image-2.6.15-1-mckinley
> (can someone tell me whats the difference betn kernel-image and 
> linux-image?).
> I have a feeling that the fact that I installed them in that order is 
> whats made my system skrewed up. Maybe I needed linux-image installed 
> before I even installed udev. Maybe thats why udev failed to configure 
> the kernel properly, maybe thats why that kernel can't find the hard 
> disk on boot?
> Or maybe I needed to install linux-image before kernel-image ... I donno...
> I thought I will try to reconfigure udev, hoping that it will fix the 
> problem. but when I run
> dpkg-reconfigure udev
> I get the following error
> /boot/initrd.img-2.6.12-1-mckinley has been altered.  Cannot update.
> So right now I am booted with 2.6.12 with keyboard and mouse not 
> working, and can't get udev or the 2.6.15 kernel to work,
> Can anyone show me a way out of this maze?
> Thanks
> Spundun
> > 
> > On my system I have two IDE controllers and sometimes their recognition
> > order is being changed.
> > 
> > I have PATA HDD attached to ICH7 controller and DVD-RW to ITE8211. So,
> > in normal case I have /dev/hde for my HDD and /dev/hda for DVD-RW. But
> > sometimes ICH7 driver is being loaded before ITE8211, and I get them
> > switched: /dev/hda for HDD and /dev/hde for DVD-RW, and I get the same
> > error as you.
> > 
> > В Вск, 02/07/2006 в 10:14 -0700, Spundun Bhatt пишет:
> >> Can someone please respond to my question over here? This *is* the right 
> >> forum, isn't it?
> >>
> >>
> >> Spundun Bhatt wrote:
> >>> Hi debian-ia64.
> >>>
> >>> I updated the kernel on my debian linux testing from 
> >>> linux-image-2.6.12-1-mckinley to linux-image-2.6.15-1-mckinley .
> >>>
> >>> When I rebooted, I got the error saying the following (very early in the 
> >>> boot).
> >>>
> >>> RAMDISK: Compressed image found at block 0
> >>> Kernel panic - not syncing: VFS: Unable to mount root fs on 
> >>> unknown-block (0,0)
> >>>
> >>> I suspect that the new kernel bootloader configuration is pointing to a 
> >>> non-existing location for root partition...
> >>>
> >>> Can anyone guide me as to how to debug this problem?
> >>> Also is there any literature available that will help me understand how 
> >>> linux boot loader works on debian on ia64? I mean what are the packages 
> >>> responsible for installing the bootloaders and where can I find the 
> >>> configuration so that I can check whether its right or not, etc?
> >>>
> >>> Thanks a lot
> >>>
> >>> Spundun
> >>>
> >>>
> >>
Покотиленко Костик <casper@meteor.dp.ua>

Reply to: