[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-faq: convert german translation into po

On Sunday 17 May 2015, at 21:00 +0200, Holger Wansing wrote:
> Hi all,


> hopefully can help me converting the german translation of debian-faq
> into a po based one.

I am not sure if I can be a great help, anyway I went through the same
process of transition to .po for debian-history and the it
language. (victory on the IRC channel was a great help and many thanks
again for that)

I will try to remember as much as I can .

> I worked through the german sgml files, to make the structure match
> the english sgml files.
> Now I tried po4a-gettextize, but it fails very early:
> ted@IBM-T60:~/deb/debian-faq/debian-faq$ po4a-gettextize -v -f sgml -m basic_defs.sgml -l de/basic_defs.sgml -p de/01.po 
> nsgmls:<OSFD>0:3:0:E: no document type declaration; will parse without validation
> po4a::sgml: Error while running nsgmls -p.  Please check if nsgmls and the DTD are installed.

What I find strange here is that you work on basic_defs.sgml file. If I
recall correctly you only have to work on debian-faq.sgml since all the
other files are included there and that is the only file mentioned in
po4a.cfg anyway.

That will also explain the complaints about "no document type
declaration" since the document type is only declared in the
debian-faq.sgml file (I think).

Another thing I had to do was to find in the archives the sgml English
version corresponding to the Italian sgml translation. otherwise the
paragraphs did not match and I did end with errors and little

Basically I did as follows.

1) Find in the archive/repo the original .sgml files corresponding to the Italian translation.

2) I used a command similar to:

po4a-gettextize -f sgml -m project-history.it.sgml -M UTF-8 -L UTF-8 -l project-history.it.sgml -p it.po

3) then I updated the .po file with the new .pot, bringing the Italian .po
file up to date (well much was fuzzy or untranslated of course :)

And from then on it was just the usual work.

Hope this helps at least a bit,


> It seems to me, there is some software missing, I looked through relevant
> package lists, installed some additional one, but with no luck.
> Any hints?
> Holger
> -- 
> ============================================================
> Created with Sylpheed 3.5.0           under   T H E   N E W
> 	D E B I A N   L I N U X   8 . 0   " J E S S I E " !
> Registered Linux User #311290 - https://linuxcounter.net/
> ============================================================
> -- 
> To UNSUBSCRIBE, email to debian-i18n-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: [🔎] 20150517210035.baf77d612ea3d3a1da38fa96@wansing-online.de">https://lists.debian.org/[🔎] 20150517210035.baf77d612ea3d3a1da38fa96@wansing-online.de

                        And the end of all our exploring
                       Will be to arrive where we started
                     And know the place for the first time.
                T.S. Eliot "Little Gidding/Four Quartets" (1942)

Attachment: signature.asc
Description: Digital signature

Reply to: