[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't get vim installed...

On Nov 21, 2007 11:03 AM, Javier Vasquez <jevv.cr@gmail.com> wrote:
> On Nov 21, 2007 4:28 AM, Michael Banck <mbanck@debian.org> wrote:
> >  ...
> >
> > Can you try this package:
> >
> > http://incoming.debian.org/aptitude_0.4.9-1+b1_hurd-i386.deb
> >
> > Yesterday's aptitude upload was built against a wrong version of apt,
> > this one, (to hit the archives in 10 hours or so) should be better.
> >
> > ...
> Done...  It seems like the ncurses based interface is buggy.  I could
> successfully set vim-runtime in hold.  The bad response comes when
> quiting aptitude, then the interface hangs and it nevers exit until a
> Ctrl-C is applied, :(...
> But it installs, and one can achieve the purposed tasks I believe,
> :)...  Actually I tried aptitude full-upgrade, and the package I set
> on hold was not tried to be updated, :)...
> If there's another version you'd like me to try, then please let me
> know, and I will as soon as I notice the message...
> ...

OK, aptitude seems more broken than I expected.  When I perform
"aptitude install ..." or select the packages with the ncurses
interface and then try to install them, all the packages are
downloaded, but as soon as they get downloaded, an error shows up:

Preconfiguring packages ...
E:  Sub-process /usr/sbin/dpkg exited unexpectedly
A package failed to install.  Trying to recover:

And the packages don't actually get configured neither installed....
So I guess a new update is required.  It sounds like the way dpkg is
being called is not suitable, btw...



Reply to: