[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gnu-latest.tar.gz

"Alfred M. Szmidt" <ams@kemisten.nu> writes:

> One thing that occured to me is that we don't support MD5 passwords (I
> can't find anything in the source that says that we do support them,
> only that we support crypt() passwords), this might have caused our
> passwd tarnslator to barf.

md5 passwords is a feature of the the crypt() function in glibc.
Worked fine last time I tried it (ok, that wasn't on the hurd, but I
see no reason why that part of glibc should be system dependent).

To configure your system to actually *use* md5 passwords is a question
of using the right magic salt when creating new password entries,
which probably requires some level of support in the passwd program.


Reply to: